Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When my computer starts the bios posts I get into the windows boot manager. There I select ubuntu. My screen goes black but with the backlight still on. Until after half a minute it turns white and my background appears(auto-login no login screen). I would like to see the log as my computer starts up. How would I fix it? I am using a dual boot with windows(infected by a Trojan horse for fourth time!) and ubuntu 12.04 LTS

Edit Note: It has been working when I didn't have my dual-screen setup Edit Note 2: I have a nvidia GeForce graphical card in my pc. (Ubuntu doesn't detect both my screens until I setup dual screen via the nvidia configuration screen

share|improve this question
add comment

1 Answer 1

Hello it sounds to me like Nvidia-config has caused troubles. For certain systems after installing the Nvidia drivers and running Nvidia-config it is possible (and more likely for dual screens) for your xorg.conf file to be generated incorrectly.

For certain (OLD) systems:

/etc/X11/xorg.conf specifies how the desktop should be displayed on your screen(s) if this is invalid you will not be able to boot into Ubuntu.

For this scenario I suggest you drop to main terminal (Ctrl+Alt+F1) (you can do this even if your desktop is not showing) and navigate to /etc/X11/ where you should have xorg.conf and xorg.conf.backup or xorg.backup.conf or some such (a backup file) you should be able to restore one of the backups (which is generated by nvidia-config). This will revert back to the old 1 screen configuration and allow you to access your desktop and fix the real problem by:

For most systems, I would recommend a reinstall of the drivers and after the re-installation attempt to auto-config again. For installing the proprietary drivers there are 2 "good" approaches:

  1. You can attempt to install via the ubuntu-x-swat repository. This is the simplest approach. Instructions can be found here.
  2. You can attempt to install the latest drivers by downloading them from the nvidia website. Then dropping to main terminal (Ctrl+Alt+F1), stopping the display service "sudo servive gdm stop" and then installing the drivers "sudo ./NVIDIA-versionxxx.sh". Towards the end of the installation you will be asked if it should auto configure say yes and hopefully this should work and you will have both screens ready to go.

Side Notes: Option (1) is easier to do and will automatically update the drivers as you update the system (essentially less maintenance). Option (2) will require you to reinstall the drivers every time the kernel is updated more maintenance but you will always have the latest proprietary drivers.

Hope that helps.

EDIT: If you decide to attempt Option(2) after Option(1) remember to remove the old drivers by "sudo apt-get remove nvidia-current"

share|improve this answer
    
You didn't understand me. I can get to my desktop there is just no boot screen –  superaxander Jun 19 '13 at 13:52
    
Also I'd rather not go to text mode because the text gets centered across both screens and some text is missing because of that –  superaxander Jun 19 '13 at 13:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.