Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install openjdk-7-jre on a 64bit Ubuntu 12.04 server as part of a Canvas LMS install.

When I run sudo apt-get install openjdk-7-jre I get:

Err http://us.archive.ubuntu.com/ubuntu/ precise-updates/universe openjdk-7-jre-headless amd64 7u21-2.3.9-0ubuntu0.12.04.1
 Connection failed

This error is repeated for security.ubuntu.com at two separate locations

I have tried using the --fix-broken flag as this was suggested at the first failure, but this has not resolved the issue.

I have installed multiple other packages with no issues, this leads me to believe the I do not have a connectivity issue to the internet or to the repository.

I have run both the apt-get update and the apt-get upgrade with no problems.

Any suggestions as I am unable to complete the LMS install without this package.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I tried manually downloading openjdk-7-jre-headless_7u21-2.3.9-0ubuntu0.12.04.1_amd64.deb from http://us.archive.ubuntu.com/ubuntu/pool/universe/o/openjdk-7/ and the file (which is ~34MB) downloaded successfully. This was less than an hour after you asked your question. Try running:

sudo apt-get install openjdk-7-jre-headless
share|improve this answer
1  
karel, thanks for getting back to me. Just trying the headless failed with the same message. However, your response pointed me to the answer. We run a Sophos WS500 proxy which I was using. It was allowing all the other packages through with no issues, but was stopping the openjdk packages because of data fragmentation..... Removed the proxy settings, set a rule on the firewall to let the server out directly - hey presto, the package now works...... –  Ross Jun 18 '13 at 23:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.