Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using WINE to run several Windows-only games that I play. Currently, in order to play the game, I must locate the file in Nautilus, right click, and Open with > WINE. If I lock the .EXE file to the Launcher, then try to run the WINE icon, then nothing happens. If I copy the .EXE Shortcut to the desktop, then I lose the option to right click & open with WINE.

What I would like to be able to do is simply designate all .EXE files to automatically open (on double left-click) with WINE.

I've searched through other questions here and other sites and have been unable to find an answer, so any help is greatly appreciated.

share|improve this question
    
What you need is a launch script.... –  Alvar Jun 18 '13 at 20:59
add comment

3 Answers 3

up vote 1 down vote accepted

I installed wine so I can answer this question better. Once wine finished installing (from Software Center)

enter image description here

I copied an EXE file over (utorrent.exe)

enter image description here

The I right clicked the file, and choose Open With --> Wine Windows Program Loader, and it opened. See image below.

enter image description here

enter image description here

share|improve this answer
    
Wine is not in the list of available applications to Open With. The option to add a program is greyed out. –  travisw Jun 18 '13 at 21:12
    
Try starting the file browser from terminal with sudo nautilus navigate to the file and try setting the default again. I too do not have wine installed. –  SimplySimon Jun 18 '13 at 21:22
    
I'll install wine and let you know a little later. –  Mitch Jun 19 '13 at 4:02
    
'sudo nautilus' doesn't seem to do it, but placing the .exe on desktop allows it to work, so problem solved! Thanks. :) –  travisw Jun 19 '13 at 18:32
    
Glad that it worked. If this answered your question, you may mark this answer as accepted. –  Mitch Jun 19 '13 at 18:43
add comment

To autorun .EXE files with WINE when you double click on them from your file manager you need to edit ~/.local/share/applications/mimeapps.list file (or /usr/share/applications/defaults.list to make this change system-wide) and add the following line at the end of the file:

application/x-ms-dos-executable=wine.desktop

A system reboot is probably necessary.

share|improve this answer
add comment
  1. Run this command in a terminal:

    sudo sed -r -i 's/^NoDisplay=(true|false)$/NoDisplay=false/' /usr/share/applications/wine.desktop
    
  2. Right click on a exe file, open "Properties" and navigate to the "Open with" tab.

  3. Locate "Wine Windows Program Loader" in the list and press "Set as default".
  4. exe files should now open in Wine by default.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.