Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I try to run sudo apt-get update and the terminal freezes and a message pops up: Ubuntu experienced an internal error... I am trying to work with OpenFOAM and all the times is asking me to update things and when I try it, it gets stuck.
Ubuntu version is 12.04.

share|improve this question
Please post your /etc/apt/sources.list file maybe it will give any clue. – Tarun Jun 18 '13 at 11:55
Thank you very much for replying. I am trying to do this but now it tells me Permission denied... – Xulia Duchamps Jun 18 '13 at 12:01
Did you tried to access it as root??? – Tarun Jun 18 '13 at 12:09
Thanks for all the help! I am sorry, I am very new to Linux. How do I access as a root? Right now I am accessing as the username I have by default in my laptop... – Xulia Duchamps Jun 18 '13 at 12:14
type the command in the terminal sudo su then type vim /etc/apt/sources.list – Tarun Jun 18 '13 at 12:16

Try this:

Make a back up copy of your sources.list:

sudo cp /etc/apt/sources.list{,.backup}

Now remove the original and update:

sudo rm /etc/apt/sources.list && sudo apt-get update
share|improve this answer
I've tried this and it tells me there is no such list...grrrr!! Sorry if it's me causing all this problems due to my ignorance..... – Xulia Duchamps Jun 18 '13 at 16:48
After many attempts I found out that I managed to disable the universe repository and that was what didn't let me update properly openFOAM. Everything solved now and I am happy I didn't have to go for the solution DELETE EVERYTHING AND INSTALL AGAIN UBUNTU ... many thanks for all the support! I hope I can start helping as well some time soon!! :) – Xulia Duchamps Jun 19 '13 at 6:49
@Xulia : Glad to hear that :) – Tarun Jun 19 '13 at 6:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.