Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I restarted my Ubuntu after it being updated, I found the Unity launch bar was gone.

I tried looking up several solutions online, blindly typing in the commands that others suggested, and I found after the umpteenth time rebooting after typing in another foreign command, I found I couldn't even open up the terminal with the Ctrl+Alt+t shortcut either and I have no idea how to fix this.

This was the last set of instructions I remember following before terminal stopped opening.

Install CCSM

sudo apt-get install compizconfig-settings-manager

And then run it in terminal (Ctrl+Alt+t)

ccsm

Then search for "Ubuntu Unity Plugin". If it's not checked, check it.

If it is checked you may have another issue. Try restarting compiz:

kill -9pidof compiz`

This will kill it, it should start up again, if it doesn't, CTRL+ALT+F2 and then type:

sudo service lightdm restart

to restart the window manager. Go back to the terminal and run:

unity --reset

share|improve this question
add comment

1 Answer 1

I just had exactly the same problem on Ubuntu 13.10. Unity launcher gone and ctrl + alt + t shortcut not working. I opened xterm by typing CTRL+ALT+F2 and tried unity --reset, but that did not work since it is deprecated in ubuntu > 12.10.

This solution worked for me:

  1. Log into unity.
  2. Right click on the desktop and create a new folder.
  3. Open the folder and go to /usr/bin and start gnome-terminal by clicking on it.
  4. Type ccsm in the terminal to start compiz config settings manager.
  5. Go to preferences -> plugin list.
  6. Uncheck the automatic plugin list. And enable all the plugins.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.