Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Few days ago I've decided to install Ubuntu 13.04 (with dual boot Windows 8) on my old laptop (Toshiba Qosmio f55 q502) and make it my media center.

Everything went well except that I don't have sound through my HDMI cable. I have tried looking for solution in other posts but with no luck. In the sound settings, I see 3 options: speakers, SPDIF, and HDMI. When I choose HDMI I'm not getting any sound in my TV. I have updated the nvidia driver (before that there was no video through HDMI as well)

Please help me to solve this issue and to forget windows for good. Thank you

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC272 Digital [ALC272 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
share|improve this question

5 Answers 5

Can you open a terminal and give me the output from

aplay -l

I had this problem in the past. I know SMPlayer can select audio outputs, so it might be worth checking out that app to see if you can get anything at all from your HDMI audio.

On SMPlayer, start up a video, then on the menu select Tools -> Preferences. On the Audio tab go for the Output Driver and change it from Pulse to one of the alsa (0.x - HDA NVidia HDMI) options. See what works.

Installing pavucontrol will also give you much better control over your individual audio outputs. HDMI output may be muted by default.

share|improve this answer
    
Hey, thank you for your reply. I have tried your devices but with no luck. In the SMPlayer i don't have any option with HDMI or Nvidia. I do have few "HDA Intel" but non of them gave sound to the TV when playing a movie. –  SHR Jun 18 '13 at 3:51
    
In pavucontrol, I have selected "Digital Stereo (HDMI) output" but just cut the sound. My output from aplay -l is –  SHR Jun 18 '13 at 3:52
    
**** List of PLAYBACK Hardware Devices **** card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: Intel [HDA Intel], device 1: ALC272 Digital [ALC272 Digital] Subdevices: 1/1 Subdevice #0: subdevice #0 –  SHR Jun 18 '13 at 3:52
    
card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0 –  SHR Jun 18 '13 at 3:52

OK... Let's try something different. Open a terminal for me and let me know if the following command makes a noise through your HDMI setup.

aplay -D hw:0,3 testsound.wav

NEW INSTRUCTIONS

Open a terminal and copy the command below

sudo gedit /etc/pulse/default.pa

Enter your password, and the configuration file for pulseaudio should open.

Look for:

load-module module-udev-detect use_ucm=0

and add a # to the start so it reads:

# load-module module-udev-detect use_ucm=0

Now go to the end of the file and add on a new line:

load-module module-alsa-sink device=hw:0,3

Save the file and reboot. This should restart your system with the HDMI audio.

share|improve this answer
    
when runung "aplay -D hw:0,3 testsound.wav testsound.wav", this is what Iv'e got: No such file or directory –  SHR Jun 18 '13 at 12:41
    
I appreciate your effort. –  SHR Jun 18 '13 at 12:43
    
Actually... this is good news. If the HDMI channel wasn't working, you would have seen a different message. Your computer is ignoring the HDMI channel when you boot. It's possible to change this. Are you OK to change configuration files? –  Drac Noc Jun 18 '13 at 16:39
    
As I said, I'm totally new in this OS, but in windows I'm more then an average user. I don't have knowledge in writing codes but I can follow instructions. What should I do or read in order to change configuration files? –  SHR Jun 18 '13 at 20:26
    
I'll change my answer... –  Drac Noc Jun 18 '13 at 20:43

Sometimes the HDMI audio is muted by default. Go into alsamixer and see if the HDMI channel is muted. Also your output of aplay -l shows only the integrated Intel Display and Audio driver, not the Nvidia one. from the aplay output card 0 is the Intel card, card 1 may be your Nvidia card. You can add the -c # parameter to specify the card # to work with.

try this in a console:

sudo alsamixer -c 1

Select the HDMI output and un-mute it if it is muted. It may just be that easy. If you don't see any devices remove the -c 1 and try again. If your HDMI audio out was already un-muted then there is a LOT of information out there on audio not playing over HDMI and it is quite a deep rabbit hole to go down.

You can also try this sound troubleshooting Procedure: https://help.ubuntu.com/community/SoundTroubleshootingProcedure

share|improve this answer
    
Thank you for you help. In alsamixer I don't have HDMI, I have Master, Headphon, PCM, Mic, S/PDIF. The Chip is Nvidia MCP77/78 HDMI –  SHR Jun 20 '13 at 1:10

In my case I had to go to Sounds Settings at the top right of the desktop, and select output: HDMI. This fixed the problem for me.

Just as reference aplay -l gives me the following:

 ****List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC1200 Analog [ALC1200 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC1200 Digital [ALC1200 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
share|improve this answer

This answer has helped me:

Try the below code in terminal

sudo gedit /etc/default/grub

Edit the line

GRUB_CMDLINE_LINUX=""

to

GRUB_CMDLINE_LINUX="radeon.audio=1"

Run:

sudo update-grub

Restart the system

Alternatively, and if this does not work, consider installing the proprietary driver for your ATI graphics card.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.