Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i used to use 12.04 LTS and had the same problem..upgraded to 12.10 as i have read somewhere that 12.10 has a fix for it...but i still face the same problem.. *i have wvdial...usb-mode switch packages *my modem also shows up in lsusb command *i have added my modem under the mobile broadband tab of network settings *enabled networking in recovery mode

NOTE:-when i boot up in the recovery mode..the option is available in the network settings to "ENABLE BROADBAND" and also my modem shows up and i am able to connect it...but i am unable to do so in the normal boot.

p.s:- i use tata photon +

share|improve this question
    
Did you check: askubuntu.com/questions/6001/… –  saji89 Dec 4 '13 at 8:32

2 Answers 2

up vote 1 down vote accepted

You may try this:

Press ALT+F2 and enter gksu gedit /etc/udev/rules.d/yourtataphoton.rules to create the file we need. Now paste the content below into the file and save it.

SUBSYSTEM="usb"
SYSFS{idProduct}="1446"
SYSFS{idVendor}="12d1"
RUN+="/lib/udev/modem-modeswitch --vendor 0x12d1 --product 0x1446 --type option-zerocd"

Now just plug in your dongle and configure your connection using NetworkManager.

Source

share|improve this answer
    
thank you for the reply...but i tried it and it aint working...did exactly the same..rebooted and even gave the device some time..but not worth the wait.. –  Yasasvee Atreya Jun 17 '13 at 16:26
    
and my /etc/usb-mode/ directory is empty...is that a problem or related to the issue ?? –  Yasasvee Atreya Jun 17 '13 at 16:28

I've got a Sony P11Z netbook with a built-in USB 3G Modem and i'm using debian, maybe my problem is the same as yours.

# lsusb -s 001:007
Bus 001 Device 007: ID 0af0:7601 Option Globetrotter MO40x 3G Modem (GTM 382)

When booting a 3.10 kernel the mobile broadband option usually is missing (but not always). When i boot a 3.2 kernel it shows up again (most often).

I checked /var/log/syslog while restarting network-manager and found these 3 lines:

Dec  4 08:31:18 plok NetworkManager[4934]: <info> rfkill0: found WiFi radio killswitch (at /sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:17/SNY5001:00/rfkill/rfkill0) (platform driver Sony Notebook Control Driver)
Dec  4 08:31:18 plok NetworkManager[4934]: <info> rfkill2: found WWAN radio killswitch (at /sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:17/SNY5001:00/rfkill/rfkill2) (platform driver Sony Notebook Control Driver)
Dec  4 08:31:18 plok NetworkManager[4934]: <info> rfkill3: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.1/0000:02:00.0/ieee80211/phy0/rfkill3) (driver ath9k)

Now i found out that, in my case, issuing the following command would bring up the device, regardless of the currently running kernel. It takes a few seconds to initialize (follow the process with tail -f /var/log/syslog), then the "mobile broadband" option would show up in gnome-network-manager.

echo 1 > /sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:17/SNY5001:00/rfkill/rfkill2/state
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.