Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just started using Ubuntu 13.04, but I can't seem to get my sound card (Tascam US-122L) up and running.

I'vce tried many tutorials, but none satisfying. Strangely, at some point, I got the computer to detect my sound card, as it got listed. But a minute later, it was gone (also even then I couldn't get it to play music)

Is there a way of installing the hardware? I also tried to install the Windows driver using WINE, but that gave an error...

lsusb output:

Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 13d3:5130 IMC Networks
Bus 002 Device 007: ID 0644:800e TEAC Corp. TASCAM US-122L
Bus 002 Device 006: ID 046d:c058 Logitech, Inc. M115 Mouse

I seem to get some response, but no sound...

Result from aplay -L:

default
   Playback/recording through the PulseAudio sound server
   sysdefault:CARD=MID
HDA Intel MID, CONEXANT Analog
   Default Audio Device
   front:CARD=MID,DEV=0
HDA Intel MID, CONEXANT Analog
   Front speakers
   surround40:CARD=MID,DEV=0
HDA Intel MID, CONEXANT Analog
   4.0 Surround output to Front and Rear speakers
   surround41:CARD=MID,DEV=0
HDA Intel MID, CONEXANT Analog
   4.1 Surround output to Front, Rear and Subwoofer speakers
   surround50:CARD=MID,DEV=0
HDA Intel MID, CONEXANT Analog
   5.0 Surround output to Front, Center and Rear speakers
   surround51:CARD=MID,DEV=0
HDA Intel MID, CONEXANT Analog
   5.1 Surround output to Front, Center, Rear and Subwoofer speakers
   surround71:CARD=MID,DEV=0
HDA Intel MID, CONEXANT Analog
   7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
   dmix:CARD=MID,DEV=0
HDA Intel MID, CONEXANT Analog
   Direct sample mixing device
   dsnoop:CARD=MID,DEV=0
HDA Intel MID, CONEXANT Analog
   Direct sample snooping device
   hw:CARD=MID,DEV=0
HDA Intel MID, CONEXANT Analog
   Direct hardware device without any conversions
   plughw:CARD=MID,DEV=0
HDA Intel MID, CONEXANT Analog
   Hardware device with all software conversions
   usb_stream:CARD=MID
HDA Intel MID
   usb_stream:CARD=US122L
   TASCAM US-122L
   hdmi:CARD=Generic,DEV=0
HD-Audio Generic, HDMI 0
HDMI Audio Output
   dmix:CARD=Generic,DEV=3
HD-Audio Generic, HDMI 0
   Direct sample mixing device
   dsnoop:CARD=Generic,DEV=3
HD-Audio Generic, HDMI 0
   Direct sample snooping device
   hw:CARD=Generic,DEV=3
HD-Audio Generic, HDMI 0
Direct hardware device without any conversions
   plughw:CARD=Generic,DEV=3
HD-Audio Generic, HDMI 0
   Hardware device with all software conversions
   usb_stream:CARD=Generic
HD-Audio Generic

Lastly cat /proc/asound/cards:

0 [MID            ]: HDA-Intel - HDA Intel MID
                  HDA Intel MID at 0xd5200000 irq 48
1 [US122L         ]: USB US-122L - TASCAM US-122L
                  TASCAM US-122L (644:800e if 0 at 002/007)
2 [Generic        ]: HDA-Intel - HD-Audio Generic
                  HD-Audio Generic at 0xd0040000

I've still haven't found the correct solution, sometimes it recognises my TASCAM, but often not, I can't seem to find the reason why sometimes it does and when it doesn't. Now if he recognises it, I still can't get it to play any sound. I get the above mentioned responses from cat /proc/asound/cards, but when trying pavucontrol, No Tascam to be found...

So I guess my question expands more then I thought:

  1. How do I get my computer to recognise the card each time
  2. If the card is recognised, how do I tell the computer to use the card for audio applications..

When following the advice of using next command:

speaker-test -D usb_stream:CARD=US122L

I get:

speaker-test 1.0.25

Playback device is usb_stream:CARD=US122L
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Access type not available for playback: Ongeldig argument
Setting of hwparams failed: Ongeldig argument

(ongeldig argument is dutch for invalid argument)

So far I've tried:

http://wiki.briata.org/doku.php?id=testing_us122l_under_linux the links referred in that document

share|improve this question
    
Welcome to Ask Ubuntu! This is an external USB-connected sound card, right? Please run lsusb in the terminal and include the output in your question. Also include the output of aplay -L and cat /proc/asound/cards. –  gertvdijk Jun 17 '13 at 12:29
    
I've edited your question to include the lsusb output. Next time and for the other commands, please update your question. Comments are not fit for this. As it's a Q&A site, additional information belongs inside the question - it's not a discussion forum. –  gertvdijk Jun 17 '13 at 13:45
    
Thanks! I've edited the last part also the way you started it! –  Wouter Devriese Jun 17 '13 at 13:51
1  
It looks like it's a bit of a PITA to get this to work as it's not well supported. I've been reading a lot of issues in systems with USB 3.0 support. Did you already try to blacklist EHCI? Please include all the things you've tried already - it would be sad if I would be answering your question with options you've already tried (and failed). As we don't have the hardware here, we are relying totally on what you provide in your question. In order to have it answerable, consider improving it in that way. –  gertvdijk Jun 17 '13 at 13:54
    
In your updated question it looks like it is working properly. Are you sure you've selected the right output device for your applications? Try pavucontrol (both program name and package name to install) to select the right output device while playing some sound. Also try speaker-test -D usb_stream:CARD=US122L from the command line and you should hear noise (Ctrl+C to quit). –  gertvdijk Jun 17 '13 at 22:40

1 Answer 1

Type the following in a terminal:

wget -c http://pub.briata.org/us-122l/.asoundrc ~/.asoundrc

Next, make sure you are a member of the audio group. Then, type in a terminal:

sudo nano /etc/security/limits.conf and enter the following:

@audio           -       rtprio          99

@audio           -       memlock         unlimited

@audio           -       nice            -10

Then press Ctrl+X and answer 'y'.

You should then be able to connect and see your tascam when you reboot. Normally you can then use jack and pulse audio with it but unfortunately there is a kernel bug that stops it from working currently. You will either need to wait for a fix or install a kernel less than 3.6.

I would suggest the following page: How can I install a realtime kernel?

When you follow the links to the kernel.org to obtain the kernel and patch - I would choose 3.4. Before you compile (and in the terminal window that you compile the kernel in when you follow the instructions) type the following:

export CFLAGS="-jX -O2 -march=native -fomit-frame-pointer -pipe"

Where X is twice the number of processor cores that your computer has (you might also try the number of processor cores plus one).

share|improve this answer
    
I don't see how changing priorities in the kernel enables support for this device. Also - do you have the very same hardware to confirm that this fixes the issue the OP is describing? –  gertvdijk Jun 17 '13 at 23:19
    
yh, I have the us122l. the rt prio works with low-latency kernels and I have assumed (wrongly) that that would be the kernel type. I mostly use ubuntu-studio which comes with the lowlatency as standard. Even if using the generic kernel standard install, I would personally recommend compiling a custom kernel with the rt-patch applied as the realtime performance, tailored to your specific platform gives much better performance in many situations over the generic. –  James Stewart Miller Jun 18 '13 at 6:49
    
But the question is not about performance... –  gertvdijk Jun 18 '13 at 6:54
    
mm, as I understand it, the rtprio, memlock and nice value (which is not strictly necessary) are necessary for jackd to work. I think it might be necessary for pulseaudio as well and might be necessary for the soundcard itself. I use the us122l for low latency audio recording. The .asoundrc card lets alsa know what the card is. –  James Stewart Miller Jun 18 '13 at 7:50
    
The other thing that might be worth mentioning is that you sometimes have to plug in and unplug the us122l about three times. To check that it has connected run the command 'udevadm monitor' and plug it in/unplug it. If the output from the above command shows something like '...changed...sound...c0...' then the card has been registered. You can then ctrl+c to exit udevadm and type 'cat /proc/asound/cards'. The us122l should be listed along with any other sound cards that you have. –  James Stewart Miller Jun 18 '13 at 7:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.