Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

While trying to install apache version 2.4.4 using the following method:

Source: http://zhuojun.info/?p=1121

Before installing Apache 2.4.4, you should install PCRE, otherwise it will not succeed. The process of installing PCRE is simple. After you downloaded it, run in terminal next commands:

sudo ./configure
sudo make
sudo make install

Download APR and APR-Util from http://apr.apache.org, unpack them to Apache directory, /srclib/apr and /srclib/apr-util (no version numbers in the directory names) and type following commands to install Apache:

sudo ./configure --with-included-apr
sudo make
sudo make install

Type following command to start Apache:

sudo /usr/local/apache2/bin/apachectl start

There may be something wrongs like:

/usr/local/apache2/bin/httpd: error while loading shared libraries: libpcre.so.1: cannot open shared object file: No such file or directory

Type following command to see httpd’s shared library dependencies:

ldd httpd

Found "libpcre.so.1 => not found", then type the following command to update links:

sudo ldconfig

Restart Apache and should work.

Everything seemed fine but when I tried to start the apache service it gives error:

root@server1:/usr/local/apache2/bin# /etc/init.d/apache2 start
 * Starting web server apache2                                                  /usr/sbin/apache2: symbol lookup error: /usr/sbin/apache2: undefined symbol: apr_ldap_url_parse
Action 'start' failed.
The Apache error log may have more information.
                                                                         [fail]

I tried to install the apr again but nothing seems to work. Please help.

The Apache log shows something like this:

[Mon Jun 17 10:31:08 2013] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.6 with Suhosin-Patch configured -- resuming normal operations
[Mon Jun 17 11:48:20 2013] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.6 with Suhosin-Patch configured -- resuming normal operations
[Mon Jun 17 15:44:36 2013] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.6 with Suhosin-Patch configured -- resuming normal operations
share|improve this question
    
It does sound like it didn't find the APR files when it was building. You definitely unpacked the APR and APR-Util sources into the srclib directory within your Apache source directory, and ran sudo ./configure --with-included-apr after that, build makeing Apache? –  David Edwards Jun 17 '13 at 12:26
    
I made the directory name /srclib and extracted the apr and apr-util in it inside directories /srclib/apr and srclib/apr-util and started building the apache it was completed and while starting it gave the error and I rectified it by the method above but now Im stuck with this apr error. –  Tarun Jun 17 '13 at 12:46
    
Unless I am misunderstanding you, it sounds like you have created a directory called srclib in the root of your filesystem. I think you need to put the directories extracted from the APR and APR-Util downloads in the srclib directory of the httpd-2.4.4 directory, before running sudo ./configure --with-included-apr followed by make. –  David Edwards Jun 17 '13 at 12:51
    
Ya I have made the directory /srclib in the root of my filesystem i.e. '/' and the contents extracted from the tar file of apr and apr-util in /srclib/apr and srclib/apr-util and not in the httpd-2.4.4 directory. –  Tarun Jun 17 '13 at 12:55
    
@David: Where should I extract the contents of the httpd-2.4.4.tar.gz file any specific directory or anywhere? –  Tarun Jun 17 '13 at 13:00

1 Answer 1

up vote 1 down vote accepted

Based on your comments, it appears that Apache is failing to start because it did not find APR when it was compiled. This is because the source files were not in the correct place when configure was run. You need to:

  • Extract the APR and APR-Util into the srclib directory within the httpd-2.4.4 directory.
  • cd to the httpd-2.4.4 directory and run:

    sudo ./configure --with-included-apr

    sudo make

    sudo make install

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.