Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Libreoffice Writer, I am trying to make all my numbered headings in the following form:

1. First title
     1.1 Subtitle
     1.2 Subtitle
2. Second title
     2.1 Subtitle
     2.2 Subtitle
         2.2.1 Subsubtitle

I tried playing around with Tools > Outline Numbering, but the best I can only get one of the following:

1. First title
     1.1 Subtitle
     1.2 Subtitle
2. Second title
     1.3 Subtitle
     1.4 Subtitle

Or

1. First title
     1.1 Subtitle
     1.2 Subtitle
2. Second title
     1.2 Subtitle
     1.3 Subtitle

Is there any way for me to put the subheading's numbering as a function of the numbering of the heading above, like in the example on the top?

I am running a .docx file in LibreOffice 4.0.3.3.

Edit: I edited this question as per suggestions in the comments.

Problem solved:

It seems like the big problem was the following. All the headings in the original file had a correct format (i.e. Heading 1, Heading 2, etc). However, they had not been correctly converted to the "corresponding" Heading 1, Heading 2, etc that Libreoffice uses (Thanks @gertvdijk). Thus, followin the steps in the accepted answer gets the job done.

Thanks!

share|improve this question
    
The example on the top is how it works out for me when using Tools > Outline Numbering. Are you sure you did not reset any counter? I guess you have probably hit the "Reset numbering" or "Continue previous numbering" context menu item. And are you applying the regular styles ("Heading 1", "Heading 2" etc.)? –  gertvdijk Jun 17 '13 at 11:52
    
I am applying the regular styles. I tried "Continuew previous numbering", but doing this for a huge document with a lot of styles is a lot of effort. Also, I am now remembering that maybe it has to do with the type of document: this document is a .docx file –  Sosi Jun 17 '13 at 13:31
    
This looks like a LibreOffice bug and as such off topic. –  user68186 Jun 17 '13 at 16:59
    
Please add answers as answers. It's perfectly fine to answer your own question here - don't include it in questions. While editing your question, edit it to properly match the situation (editing an OOXML file, etc.). –  gertvdijk Jun 17 '13 at 22:03
    
Hi Sosi. Your remark about tools/outline numbering... is right. You should look into my edited answer again. I do think there are several ways of doing this. –  don.joey Jun 18 '13 at 8:49

1 Answer 1

up vote 5 down vote accepted

Just

  1. Hit F11 which opens the styles and apply the styles to heading 1 to 3.
  2. Put your cursor in one of the headings and hit Format/Bullets and Numbering... (update: and not Tools/Outline Numbering... as mentioned before) in the menu bar.
  3. Then select the tab outline and choose the option numeric with all sublevels (see image)

enter image description here

In the position tab of 'Bullets and Numbering' you can choose... their position of course. If you want the typical indent you suggest, just click default in the three different levels.

Enjoy.

enter image description here

share|improve this answer
    
I have no tab Outline in the Outline Numbering window. Screenshot: i.imgur.com/4DRthHZ.png Also, I am now remembering that maybe it has to do with the type of document: this document is a .docx file –  Sosi Jun 17 '13 at 13:26
    
I have updated my answer, see comments on your question. –  don.joey Jun 18 '13 at 8:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.