Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Running Ubuntu 13.04, I have a problem with my wifi. When booting after a proper shut down, there's never any wifi connection. The system states

Wifi is disabled by hardware switch

However, pressing the hardware switch doesn't change anything.

The only workaround I have is to plug in an ethernet cable, wait for connection, then remove it. Now, a wifi connection can be established. The hardware button now functions as expected.

This is of course very annoying. First, the wifi shouldn't been disabled if it wasn't before the last shut down. Second, it should be capable of turning it on by pressing the button which is supposedly turned off. Third, it shouldn't magically flip the button through the wonderful presence of an ethernet cable. And as a bonus: It would be nice to have the state of the wifi button displayed with the little LED next to the wifi button (which it did on Ubuntu 12.04 and every other decent operating system I ran so far).

The hardware I'm working with is a Broadcom BCM4313 802.11b/g/n Wireless LAN Controller.


Now of course I tried to enable the proprietary driver for this wifi controller, but it still has issues:

After a proper boot, wifi is not connecting, not ever. Disabling the currently active (with LED correctly indicating the status, woohoo!) wifi via hardware button and turning it on again, does not change anything. The only workaround is -- again -- plugging in an ethernet cable and removing it.


Well I don't always have an ethernet cable with me, I'm not always at home and afaik I also need something on the other side of the cable otherwise it's not even detected, so this just isn't a solution.

Is there a proper fix for this? Otherwise, is there a software way to trick Ubuntu into thinking that a wired connection has been made?

share|improve this question
    
possibly this helps: askubuntu.com/questions/289609/… ? –  Christoph Jun 17 '13 at 13:46
    
@Christoph I'm always hesistant of executing commands with sudo. Can you assert that performing sudo modprobe wl doesn't destroy anything? –  stefan Jun 17 '13 at 13:52
    
no I can't. Some more info about what modprobe does: en.wikipedia.org/wiki/Modprobe linux.die.net/man/8/modprobe –  Christoph Jun 17 '13 at 13:56
    
I've tried it now, sadly no effect at all. –  stefan Jun 17 '13 at 14:16
    
I had the same problem a while back with a different chip. This won't work for you, but maybe you can glean something useful from it: askubuntu.com/questions/166328/… –  Christoph Jun 17 '13 at 15:00

3 Answers 3

Apparently this is part of a bigger problem with certain Broadcom chips, see https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1097519

Instead use the driver brcmsmac, that actually works with BCM4313

Also, there's loads of info here, but I haven't looked through it all, may be you find something relevant

share|improve this answer
    
Sadly, this did not help. –  stefan Jun 17 '13 at 14:16

try rfkill unblock all

rfkill enables and disables wireless devices

share|improve this answer

try

 rfkill unblock wlan0

it will switch wlan0 or other wireless

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.