Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was trying to update my ubuntu from 12.10 to 13.04 via command line (update manager wasn't displaying the new release). However, right after I ran sudo do-release-upgrade, the command line gave me this:

 Checking for a new Ubuntu release
 Traceback (most recent call last):
 File "/usr/bin/do-release-upgrade", line 145, in <module>
 fetcher.run_options += ["--mode=%s" % options.mode,
 AttributeError: type object 'DistUpgradeFetcherCore' has no attribute 'run_options'

How do I fix this? Thanks!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

To fix this, edit your /etc/apt/sources.list and make sure you have the following two lines:

deb http://gb.archive.ubuntu.com/ubuntu/ quantal-updates main restricted
deb-src http://gb.archive.ubuntu.com/ubuntu/ quantal-updates main restricted

After making sure you have these lines, get yourself updated again and re-try the release upgrade script:

apt-get update
apt-get upgrade
do-release-upgrade

P.S. change your country code..Like here it is gb for Great Britain.

share|improve this answer
    
Your answer would be improved if you added information generalizing the second and third lines of your answer to the case of someone who doesn't live in Great Britain, by substituting the relevant 2-character nation code for the string "gb". –  karel Jun 17 '13 at 5:40
    
thanks it worked! –  Andrew Jun 17 '13 at 6:06
    
@karel...Ohh yes certainly...thanks for poinitng it out. –  Sankalp Mishra Jun 17 '13 at 6:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.