Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.04.2 LTS and I had thought I had permanently disabled the touch pad by

  • updating system settings to reflect my preferences
  • running a one time 'gsettings set org.gnome.settings-daemon.peripherals.mouse middle-button-enabled true'
  • running 'xinput set-prop 12 "Device Enabled" 0' in my $HOME/.bashrc

This setup works fine, when I lock the screen and unlock it. However, after my session gets suspended because of inactivity followed by unlock of the screen, the touch pad is no longer disabled.

Attempt to launch the app touchpad-indicator(version 0.8.1.1-1ubunt) as a possible remedy crashes at startup.

Is there a better solution than, rerunning xinput set-prop 12 "Device Enabled" 0 every time I log into my session after a suspend?

share|improve this question

2 Answers 2

I wrote this script to disable the touchpad on my system:

#!/bin/bash

# fix touchpad - turn off tap to click
/usr/bin/synclient MaxTapTime=0

# turn off touchpad entirelly. Assuming Touchpad is Device 12.
# xinput set-prop 12 "Device Enabled" 0
xinput set-prop "AlpsPS/2 ALPS DualPoint TouchPad" "Device Enabled" 0
# Touchpad device number can be checked with
# xinput list

The script is run at login time but needs to be manually rerun after resuming from suspend. I manually run it with a shortcut created on my panel.

You could probably automate it with a few modifications and placing it in /etc/pm/sleep.d/. That's not an option for my as the computer is a multi-user system and the other users want the touchpad.

share|improve this answer

You can disable it entirely using synclient.

First, type the following in a terminal to check whether it works correctly:

synclient TouchpadOff=1

This should disable it for the rest of the session (synclient TouchpadOff=0 will reverse this). You can do this per-session (it will revert whenever you log out), but it is also possible to have the setting persist.

To make this change permanent (i.e. to have it work after reboot), in a terminal, cd /usr/share/X11/xorg.conf.d. ls to find the file with "synaptics.conf" in the name (in my case, 50-synaptics.conf). Then, type sudo gedit 50-synaptics.conf, and add the following line into the end of the first InputClass section:

option "TouchpadOff" "1"

Restart your computer; your touchpad should now be switched off.

If editing the 50-synaptics.conf file doesn't work, do the following: open dconf-editor and navigate to org/gnome/settings-daemon/plugins/mouse. Uncheck the box marked "active" and restart again. This will allow the synaptics settings to take precedence.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.