Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed a webserver, and port 80 is open. I can connect with 127.0.0.1 and 192.168.0.50, but I can't with my external IP. So, why is this?

I use a router from Ubee.

share|improve this question
    
Success: I can see your service on 68.202.xxx.xxx on port (80) Your ISP is not blocking port 80 –  Chimerica Jun 16 '13 at 19:45
    
Are you still having this problem? –  Seth Jun 16 '13 at 19:50
    
Yes, I am. I have not found a solution. I have added my internal into the DMZ host area, and still the same problem. Advanced Gateway - DMZ Host (Exposed Host) DMZ Address 192.168.0.50 –  Chimerica Jun 16 '13 at 19:50
    
Is this server connected to the internet through a router? –  Seth Jun 16 '13 at 19:55
    
Yes, it is. It's an Ubee router. –  Chimerica Jun 16 '13 at 19:55

2 Answers 2

up vote 1 down vote accepted

If you are connecting via a router you will have to configure that router to "forward" packets to your server. How that can be done depends on the router, sometimes you will find the setting under DMZ, sometimes under services.

It will look like:

  • external port (probably 80)
  • internal host to forward it to (192.168.0.50)
  • port on the destination to use (again 80)

Seth found a guide for your router: Port Forwarding the Ubee U10C022-Ambit Router for Apache

share|improve this answer
    
Here's a guide for an Ubee router and Apache: portforward.com/english/routers/port_forwarding/Ubee/… –  Seth Jun 16 '13 at 20:00
    
@Chimerica I get "It works!" the default Apache message when it installed right. –  Seth Jun 16 '13 at 20:06
    
I can not connect to it, and neither can my friend (who I'm setting up a cPanel for.) I get the same problem with :8080. –  Chimerica Jun 16 '13 at 20:10
    
i.imgur.com/2maPhvf.png –  Chimerica Jun 16 '13 at 20:11
    
I can't just solo out 4 ports, as you see. I got 80, 2011, 2012, 25564 and 25565 –  Chimerica Jun 16 '13 at 20:17

Along with gunbert's solution there may be another problem preventing you from accessing the server outside of your LAN.

Depending on where you live, certain ISPs prevent certain kind of external access to their customers. The most common of these would be port 80.

If port forwarding doesn't work, look online for what ports your ISP filters.

share|improve this answer
    
Thanks for the info, cdbitesky. –  Chimerica Jun 17 '13 at 2:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.