Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 12.10, gedit 3.6.1

This won't work:

gconftool-2 --type int --set /apps/gedit- /preferences/ui/recents/max_recents 30

Modifying this file as root won't work either:

cat /usr/share/glib-2.0/schemas/org.gnome.gedit.gschema.xml |grep rece -C 1

EDIT: there is nothing at gconf-editor either.

Is it hard coded? In order to increase the number of recent files in gedit from its default of 5 will I need to find, "fix" and recompile gedit with the answer here?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Using the dconf-editor, this value can be found in the schema under org.gnome.gedit.preferences.ui. The value that you want to change is called max.recents.

dconf-editor can be installed from USC here:

Install via the software center

or from a command line using: sudo apt-get install dconf-tools

share|improve this answer
1  
worked thanks! btw, about all these configuration tools, this is so confuse, we have gconf-editor, dconf-editor, gconftool-2, I think there is more also.. would be easier if they made something unified like linux-regedit... –  Aquarius Power Jun 17 '13 at 14:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.