Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed ubuntu on my laptop. I can't ping or open a site with it's name but everything works fine when i use IP address. I already tested a few ways like disabling ipv6, changing dns server and changing some configuration in firefox.

share|improve this question
1  
change your dns to 8.8.8.8 & then run " sudo service network-manager restart " check if its working –  Qasim Jun 16 '13 at 17:23
    
Is not working, I tried this before –  user167708 Jun 16 '13 at 18:42
1  
This has nothing to do with ipv6, unless you actively tried to enable but wasn't successful. This has to do with DNS. What are the contents of /etc/hosts and /etc/resolve.conf? Look and update your question with the contents of those files. And yes,tell us exactly what you have tried. If a test fail, undo any change you done. –  Anders Jun 18 '13 at 8:49

2 Answers 2

it is an error in DNS server settings. DNS is service translating domain names to the IP addresses. Your DNS server is not set properly or does not work properly. Usually this can happen if you set fixed IP address with incorrect DNS. The advice in comment to setup DNS to 8.8.8.8 is correct and can help you, but better will be, if you use your local DNS, usually it is given from your provider or it can be IP address of your local router. For most cases to setup DHCP (automatic IP setup) will work.

share|improve this answer
    
Is not working, I tried this before –  user167708 Jun 16 '13 at 18:17

Please attach results from

  • dmesg | grep eth
  • ifconfig eth0 (or from interface you are connected) and
  • dhclient commands.

Try to diagnose DNS problems by

  • ping to your DNS and
  • dig www.google.com. If there would be a message like "no servers could be reached" look into /etc/resolv.conf.

Please attach result from all of them, so we can diagnose the trouble.

Be careful, this information could be read by anyone. If your system is on public fixed IP and system should be secure, better would be to find local specialist or to anonymize your IP addresses.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.