Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am using ubuntu 12.10. I use a ZTE USB 3G Modem to connect to internet. I connect that modem through a driver software which was provided with the modem. This modem works fine. I can browse , use apt-get through terminal. But the problem is network-manager cant detect my modem. It shows nothing in the top bar. Because of this I -

  1. Can't use Ubuntu Software Center
  2. Can't use VPN services
  3. Can't create wifi hotspot

First of all i am telling what i have noticed about this modem:

  1. When I connect this modem first time that driver software can't detect it. This time ' lsusb ' command give this lsusb(before) . After unplugging and plugging for 2-3 times that software can detect modem and output of lsusb changed to lsusb(new). And ths time ubuntu also find a cd-rom by which driver software is delivered. But if i connect modem before starting Ubuntu that driver software can detect modem at first time!!
  2. I have tried to connect this modem through ' Mobile Broadband ' option but unfortunately this option can't detect my modem under ' create a connection for this mobile broadband device ' option.
  3. I think that driver software use wvdial to connect to the internet as I have to install wvdial before installing that software. I have tried to connect to internet using wvdial from terminal. wvdial works fine. And I can use internet. But can't solve network-manager problem.
  4. Also used sakis3g. sakis3g can connect my modem but this also can't solve the network-manager problem.

Now I am telling what I have done till now to solve that network-manager problem:

I have tried this code with root privilege:

echo vendor productID > /sys/bus/usb-serial/drivers/option1/new_id

It didn't work.

One more thing its confusing what will be my productID for this code 0154(which lsusb finds before modem gets detected by driver software)? or 2003(which lsusb finds after modem gets detected by driver software and find a cd-rom)?

I think usb_modeswitch can help me solving this problem but i don't know how to use usb_modeswitch or create configuration file with it.

Thats all. Now my question is whats wrong? Is there any solution to get my modem detected by network-manager?

share|improve this question
You have to find the vendor/product ids from the output from lsusb, then replace the respective text in the commands. (e.g. echo vendor productID > /sys/bus/usb-serial/drivers/option1/new_id) –  Yet Another User Jun 16 '13 at 15:28
actually I have replaced vendor productID with my lsusb output. @ Yet Another User –  Ashfaqur Rahman Jun 16 '13 at 15:43
Same issue here! –  Naveen Jul 20 '13 at 2:04
Got No Answer Yet To This Questions! :( .If you can find something please let me know through mail.@Naveen –  Ashfaqur Rahman Jul 23 '13 at 14:58

2 Answers 2

I have solved my problem. Just visit this site -

It contains a friendly forum too.

share|improve this answer

The basic problem seems that the usb_modeswitch package distributed with ubuntu is an older version, so that many of the new USB modems are not detected.

I had the same problem - the dialler worked and the modem was usable, but the network manager did not detect the modem and so no VPN.

I uninstalled the driver and then USB CD drive is detected if the modem is plugged in on restart, else the ID(19d2:0154) is shown in lsusb, but no storage device is mounted. In both cases i was able to do 'eject /dev/sr1' to switch the device to modem (19d2:2003) and the network manager detects the mobile broadband connection but disconnects after about ten minutes.

Then i updated the usb_modeswitch package for the latest and i am able to use the modem on plugin as well as on reboot.

share|improve this answer

protected by Community May 19 at 17:30

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.