Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm packaging a couple of libraries that have some dependencies with one-another.

To simplify, let's say I have: libA and libB.

libB depends on libA for both building and installing.

libA depends on libboost-system-dev (>= 1.49) for building, and libboost-system (>= 1.49) for installing.

libA's package builds successfully using cowbuilder but when trying to build libB's package, I get the following error:

The following packages have unmet dependencies:
 libA1 : Depends: libboost-system (>= 1.49) which is a virtual package.
Unable to resolve dependencies!  Giving up...

Obviously, cowbuilder does not know which libboost-system package to install.

I'd like to avoid having to write libboost-system1.49 in libA's installation dependencies so that it always uses the latest available boost version.

How can I fix that ?

share|improve this question
    
Does this not get taken care of by dpkg-shlibdeps? As per debian.org/doc/debian-policy/… –  arand Jul 19 '13 at 22:59

1 Answer 1

libboost-system1.49.0 is available only for vesions Ubuntu 12.10 or later.(See this). liba avilable for 12.10 is liba52-0.7.4. (see this). Reason for libboost-system1.49 is not available may be you are running on a older Ubuntu version.

You can download libboost-system1.49.0 .deb package for Ubuntu 11.10 from Launchpad

You can also download libboost-system1.49.0 .deb package for Ubuntu 12.04 from Launchpad

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.