Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can play some mkv videos but some others can't play. Why? I don't want to install ubuntu-restricted-extras cause it brings Adobe Flash that has not been supported again and it is the old version. And it is not easy to uninstall.

enter image description here

share|improve this question
    
What do you mean it's not easy to uninstall? It is... –  RolandiXor Jun 16 '13 at 0:01
    
sorry my english is not good. I am an Indonesian. once I install adobe flash plugin, it can't be uninstalled properly. maybe it deny to be removed. –  obysr Jun 16 '13 at 0:28

1 Answer 1

You just have to install the gstreamer ugly plugins that includes the h264 codecs:

➜  ~  apt-cache show gstreamer1.0-plugins-ugly | grep Gstreamer-Encoders
Gstreamer-Encoders: audio/AMR; audio/mpeg, mpegversion=(int)1, layer=(int){ 3, 2 };
video/x-h264, stream-format=(string){ avc, byte-stream },
alignment=(string)au, profile=(string){ high-4:4:4, high-4:2:2, high-10,
high, main, baseline, constrained-baseline, high-4:4:4-intra, high-4:2:2-intra, high-10-intra }

So, just run:

sudo apt-get install gstreamer1.0-plugins-ugly

or

sudo apt-get install gstreamer0.10-plugins-ugly

and it's done. You don't need to install anything else, nor use the ubuntu-restricted-extras package.

share|improve this answer
    
h.264 decoding is done for gstreamer apps via the libav or ffmpeg plugins. Some older versions were unable to decode High 4:4:4 Predictive which has been the default for the real FFmpeg for some time. (though no longer the case for recent gst libav plugins. This may have been the orig. posters issue, may of not, hard to tell at this point.. –  doug May 1 at 21:03
    
@doug weird, for 1.0 Gstreamer the gstreamer plugin page states support for the h264 high-4:4:4 and high-4:4:4-intra. Nothing about predictive :/. –  Braiam May 1 at 21:11
    
Braiam - your right - I went back & checked my old bug report on this. It was in 13.04 but only during the dev, at some point High 4:4:4 Predictive started working again, sorry about that. –  doug May 1 at 22:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.