Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to use my Presonus FP10 with jack and Ardour in Ubuntu 12.04 (64 bit). Here are some outputs:

kane@tripkane:~$ ffado-test ListDevices
Cannot create thread 1 Operation not permitted
-----------------------------------------------
FFADO test and diagnostic utility
Part of the FFADO project -- www.ffado.org
Version: 2.999.0-
(C) 2008, Daniel Wagner, Pieter Palmers
This program comes with ABSOLUTELY NO WARRANTY.
-----------------------------------------------

=== 1394 PORT 0 ===
Node id  GUID                  VendorId     ModelId   Vendor - Model
0       0x000a9200c7110007  0x00000A92  0x00010066   Presonus  - PreSonus FP10
ERROR: messagebuffer not initialized: 01449050994: Error (configrom.cpp)[150]
    initialize: Could not parse config rom of node 1 on port 0

Using:

sudo lshw

The following result for firewire is presented:

    *-firewire
    description: FireWire (IEEE 1394)
    product: IEEE 1394 Host Controller
    vendor: JMicron Technology Corp.
    physical id: 0
    bus info: pci@0000:05:00.0
    version: 30
    width: 32 bits
    clock: 33MHz
    capabilities: pm pciexpress msi ohci bus_master cap_list
    configuration: driver=firewire_ohci latency=0
    resources: irq:19 memory:f6801000-f68017ff memory:f6800000-f68000ff

It was recommended to "enable raw 1394 access" via Ubuntu Studio Controls which I have done. Looking around on FFADO, Ubuntu forums, and everywhere else on the net when I use the recommended settings that other people employed to get their FP10's working the following log is output from jack: (settings: priority 70, firewire as driver, realtime parameter)

02:40:09.131 Patchbay deactivated.
02:40:09.132 Statistics reset.
02:40:09.136 ALSA connection change.
02:40:09.146 D-BUS: Service is available (org.jackaudio.service aka jackdbus).
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
02:40:09.153 ALSA connection graph change.
02:40:30.252 D-BUS: JACK server could not be started. Sorry
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
Sun Jun 16 02:40:30 2013: Starting jack server...
Sun Jun 16 02:40:30 2013: JACK server starting in realtime mode with priority 70
Sun Jun 16 02:40:30 2013: [1m[31mERROR: Cannot lock down 82246176 byte memory area (Cannot allocate memory)[0m
Sun Jun 16 02:40:30 2013: [1m[31mERROR: firewire ERR: FFADO: Error creating virtual device[0m
Sun Jun 16 02:40:30 2013: [1m[31mERROR: Cannot attach audio driver[0m
Sun Jun 16 02:40:30 2013: [1m[31mERROR: JackServer::Open() failed with -1[0m
Sun Jun 16 02:40:30 2013: [1m[31mERROR: Failed to open server[0m
Sun Jun 16 02:40:31 2013: Saving settings to "/home/kane/.config/jack/conf.xml" ...
02:40:35.950 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started

When I start jack with default settings: (alsa driver) it works ok.

Most interestingly when I run qjackctl as super user, the blue light indicating the FP10 works actually switches on, but my system completely freezes and I have to turn the comp off.

I'm not sure what other information might be helpful in helping to solve the issue.

Thanks in advance,

Kane

EDIT: I have looked more into other threads/posts, installed ubuntu-studio-recording package and adjusted the rtirq file so that firewire is the highest priority after rtc and used recommended JACK settings for the FP10 by other users who have successfully got the device operating: driver = firewire, interface = hw:0, realtime = unselected. This isntantly gets the blue light to work and appears to run ok apart from message from JACK saying: "Cannot lock down 82246176 byte memory area (Cannot allocate memory)" Further reading elsewhere requested outputs of the below:

/etc/security/limits.d/audio.conf

Contents are:

# Provided by the jackd package.
#
# Changes to this file will be preserved.
#
# If you want to enable/disable realtime permissions, run
#
#    dpkg-reconfigure -p high jackd

@audio   -  rtprio     95
@audio   -  memlock    unlimited
#@audio   -  nice      -19

and

# /etc/security/limits.conf
#
#Each line describes a limit for a user in the form:
#
#<domain>        <type>  <item>  <value>
#
#Where:
#<domain> can be:
#        - an user name
#        - a group name, with @group syntax
#        - the wildcard *, for default entry
#        - the wildcard %, can be also used with %group syntax,
#                 for maxlogin limit
#        - NOTE: group and wildcard limits are not applied to root.
#          To apply a limit to the root user, <domain> must be
#          the literal username root.
#
#<type> can have the two values:
#        - "soft" for enforcing the soft limits
#        - "hard" for enforcing hard limits
#
#<item> can be one of the following:
#        - core - limits the core file size (KB)
#        - data - max data size (KB)
#        - fsize - maximum filesize (KB)
#        - memlock - max locked-in-memory address space (KB)
#        - nofile - max number of open files
#        - rss - max resident set size (KB)
#        - stack - max stack size (KB)
#        - cpu - max CPU time (MIN)
#        - nproc - max number of processes
#        - as - address space limit (KB)
#        - maxlogins - max number of logins for this user
#        - maxsyslogins - max number of logins on the system
#        - priority - the priority to run user process with
#        - locks - max number of file locks the user can hold
#        - sigpending - max number of pending signals
#        - msgqueue - max memory used by POSIX message queues (bytes)
#        - nice - max nice priority allowed to raise to values: [-20, 19]
#        - rtprio - max realtime priority
#        - chroot - change root to directory (Debian-specific)
#
#<domain>      <type>  <item>         <value>
#

#*               soft    core            0
#root            hard    core            100000
#*               hard    rss             10000
#@student        hard    nproc           20
#@faculty        soft    nproc           20
#@faculty        hard    nproc           50
#ftp             hard    nproc           0
#ftp             -       chroot          /ftp
#@student        -       maxlogins       4

# End of file


lspci | grep -i -e 1394 -e firewire
05:00.0 FireWire (IEEE 1394): JMicron Technology Corp. IEEE 1394 Host Controller    (rev 30)
share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.