Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I just got Wake on Lan working but I have a problem: If I wake on lan and try to shutdown or suspend it just starts up again. This only happens once after using WOL and then it successfully shuts down and also suspends. What could be causing this? How should I troubleshoot?

Thanks

share|improve this question
1  
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Seth Jun 15 '13 at 16:25
    
A related question: On shutdown, computer reboots when started via wake on lan –  Lekensteyn Jun 27 '13 at 12:29

2 Answers 2

I had this behaviour and fixed it by replacing the driver for my Realtek RTL111/8168B NIC. Instead of using the r8169 driver included in the kernel I used the realtek r8168 driver from realtek (inspired by this post).

Note, I'd tried to upgrade my way out of the problem by installing a 3.10 kernel which unfortunately prevents the realtek driver from building until I applied the patch from (I don't have enough reputation for a third link so google 'r8168 NETIF_F_HW_VLAN_RX undeclared' and click first link). Unfortunately the patch had white space issues that I ended up manually fixing before it would apply.

share|improve this answer
    
Is this the link that you are referring to: code.google.com/p/r8168/issues/detail?id=13 ? If,so, I can add it to your answer. –  Kevin Bowen Aug 19 '13 at 1:55

I had this same problem with 100% reproducibility, the first power off after a wake-on-lan power on would result in an immediate and undesired re-power on. But only one.

I tried lots of suggestions, even using Realtek's own kernel driver, but nothing worked. Finally I upgraded my motherboard's bios and the problem was fixed.

I have a P8Z77-V-LK ASUS motherboard. The working bios I updated to is P8Z77-V-LK-ASUS-1402. The old dysfunctional bios was 1301.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.