Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After installing steam via ubuntu software center and also after downloading the .deb file from the steam website I get the same error after launching the program. After it connects to the internet and downloading an update it gives me the error "failed to load" After searching the internet I see that others have had the same message. Yet I cannot see a solution. I also have seen that certain libraries are required to run steam. How do I install these?

share|improve this question
Go into the terminal and type sudo steam reset. Then try it again. If that doesn't work sudo apt-get remove && sudo apt-get purge steam – user140393 Jun 15 '13 at 15:44
I have tried this. I also deleted my /home/user/.steam directories as well as /home/user/.local/Share/Steam directories and started again. I have done these processes with the steam installed from the ubuntu repositories and from the website itself. Each time I "sudo apt-get purge" and reinstall. I have to download the 150 000 kb update. the 1185 update. each time getting the same error. I have noticed that when I run steam from the terminal I get this error also: Corrupt package file (/home/simon/.local/share/Steam/package/‌​112edf530704888) – Simon James Jun 16 '13 at 16:24

Remove your ~/.steam directory and run steam again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.