Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded from 11.10 (Oneiric Ocelot) to 12.04.2 LTS (Precise Pangolin) (64 bit version) and suddenly my wireless internet connection has become intermittent.

For example, when I am loading a website, it could require a few refreshes before it actually loads. Most of the time web pages and downloads work totally fine but every 10-15 minutes there may be a blip of 5-10 seconds in internet connectivity.

I especially notice this when going onto sites with https:// like Facebook, Google Mail and I also noticed it in YouTube, where a video now no longer ever loads fully (very frustrating!).

I have tried to Google this issue and indeed there are a lot of people with the same issue but the solutions are not very clear and neither is the exact problem.

Some have said it has something to do with the change to DNS resolving with the introduction of resolvconf in 12.04. Also, there are many possible problems and solutions at the following link: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/989900

I have tried to describe the problem as best as possible, however I am a novice and do not know how to diagnose the exact issue and find a solution to it. So in your comments & answers please be as simple and precise as possible.


Hardware Information

General

  • Laptop: Acer Aspire S3
  • Processor: Intel® Core™ i5-3317U CPU @ 1.70GHz × 4
  • OS type: 64-bit

sudo lshw -C network

  • description: Wireless interface
  • product: AR9462 Wireless Network Adapter
  • vendor: Atheros Communications Inc.
  • physical id: 0
  • bus info: pci@0000:02:00.0
  • logical name: wlan0
  • version: 01
  • serial: 08:3e:8e:07:3f:f1
  • width: 64 bits
  • clock: 33MHz
  • capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless -configuration: broadcast=yes driver=ath9k driverversion=3.5.0-34-generic firmware=N/A ip=192.168.2.4 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
  • resources: irq:19 memory:c0400000-c047ffff memory:afb00000-afb0ffff

sudo lspci -nn

  • 02:00.0 Network controller [0280]: Atheros Communications Inc. AR9462 Wireless Network Adapter [168c:0034] (rev 01)
share|improve this question
    
Is your internet connection dropping and restarting - i.e. does your network manager icon constantly refreshes? Can you add to your question what DNS resolution tips you have tried? Have you confirmed that it isnt just your internet provider that is causing these issues - i.e. connected via a wired connection and connect via a second computer? –  fossfreedom Jun 16 '13 at 9:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.