Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello everyone I really am new to this Ubuntu thing. I am now running the latest Ubuntu and windows on the same PC. Wireless connections work fine on windows but connects and disconnects on Ubuntu.

I am on ADSL with wireless router (Belkin and Belkin wireless network adaptor).

russell@ubuntu:~$ dmesg | grep rt 
[ 0.000000] KERNEL supported cpus: 
[ 0.000000] Movable zone start PFN for each node 
[ 0.000000] ACPI: PM-Timer IO Port: 0x408 
[ 0.000000] Allocating PCI resources starting at 80000000 (gap: 80000000:50000000) 
[ 0.000000] Booting paravirtualized kernel on bare hardware 
[ 0.000000] Enabling unmasked SIMD FPU exception support... done. 
[ 0.000000] virtual kernel memory layout: 
[ 0.004287] mce: CPU supports 4 MCE banks 
[ 0.035629] ftrace: converting mcount calls to 0f 1f 44 00 00 
[ 0.185268] ACPI: (supports S0 S1 S4 S5)
[ 0.193969] pci 0000:00:1c.0: PME# supported from D0 D3hot D3cold 
[ 0.194048] pci 0000:00:1d.0: reg 20 io port: [0xbc00-0xbc1f] 
[ 0.194117] pci 0000:00:1d.1: reg 20 io port: [0xb000-0xb01f] 
[ 0.194189] pci 0000:00:1d.2: reg 20 io port: [0xb400-0xb41f] 
[ 0.194257] pci 0000:00:1d.3: reg 20 io port: [0xb800-0xb81f] 
[ 0.194485] pci 0000:00:1e.2: reg 10 io port: [0xc000-0xc0ff] 
[ 0.194495] pci 0000:00:1e.2: reg 14 io port: [0xc400-0xc43f] 
[ 0.194554] pci 0000:00:1e.2: PME# supported from D0 D3hot D3cold
[ 0.193969] pci 0000:00:1c.0: PME# supported from D0 D3hot D3cold 
[ 0.194048] pci 0000:00:1d.0: reg 20 io port: [0xbc00-0xbc1f] 
[ 0.194117] pci 0000:00:1d.1: reg 20 io port: [0xb000-0xb01f] 
[ 0.194189] pci 0000:00:1d.2: reg 20 io port: [0xb400-0xb41f] 
[ 0.194257] pci 0000:00:1d.3: reg 20 io port: [0xb800-0xb81f] 
[ 0.194485] pci 0000:00:1e.2: reg 10 io port: [0xc000-0xc0ff] 
[ 0.194495] pci 0000:00:1e.2: reg 14 io port: [0xc400-0xc43f] 
[ 0.194554] pci 0000:00:1e.2: PME# supported from D0 D3hot D3cold
[ 0.194714] pci 0000:00:1f.1: reg 10 io port: [0x00-0x07] 
[ 0.194724] pci 0000:00:1f.1: reg 14 io port: [0x00-0x03] 
[ 0.194735] pci 0000:00:1f.1: reg 18 io port: [0x00-0x07] 
[ 0.194746] pci 0000:00:1f.1: reg 1c io port: [0x00-0x03] 
[ 0.194759] pci 0000:00:1f.1: reg 20 io port: [0xf000-0xf00f] 
[ 0.194819] pci 0000:00:1f.2: reg 10 io port: [0xd000-0xd007] 
[ 0.194829] pci 0000:00:1f.2: reg 14 io port: [0xd400-0xd403]
[ 0.194714] pci 0000:00:1f.1: reg 10 io port: [0x00-0x07] 
[ 0.194724] pci 0000:00:1f.1: reg 14 io port: [0x00-0x03] 
[ 0.194735] pci 0000:00:1f.1: reg 18 io port: [0x00-0x07] 
[ 0.194746] pci 0000:00:1f.1: reg 1c io port: [0x00-0x03] 
[ 0.194759] pci 0000:00:1f.1: reg 20 io port: [0xf000-0xf00f] 
[ 0.194819] pci 0000:00:1f.2: reg 10 io port: [0xd000-0xd007] 
[ 0.194829] pci 0000:00:1f.2: reg 14 io port: [0xd400-0xd403]
[ 0.194839] pci 0000:00:1f.2: reg 18 io port: [0xd800-0xd807] 
[ 0.194848] pci 0000:00:1f.2: reg 1c io port: [0xdc00-0xdc03] 
[ 0.194858] pci 0000:00:1f.2: reg 20 io port: [0xe000-0xe00f] 
[ 0.194892] pci 0000:00:1f.2: PME# supported from D3hot 
[ 0.194957] pci 0000:00:1f.3: reg 20 io port: [0x500-0x51f] 
[ 0.195097] pci 0000:01:00.0: reg 24 io port: [0x9000-0x907f] 
[ 0.195212] pci 0000:00:1c.0: bridge io port: [0x9000-0x9fff] 
[ 0.195287] pci 0000:02:05.0: reg 10 io port: [0xa000-0xa0ff] 
[ 0.195360] pci 0000:02:05.0: supports D1 D2
[ 0.194839] pci 0000:00:1f.2: reg 18 io port: [0xd800-0xd807] 
[ 0.194848] pci 0000:00:1f.2: reg 1c io port: [0xdc00-0xdc03] 
[ 0.194858] pci 0000:00:1f.2: reg 20 io port: [0xe000-0xe00f] 
[ 0.194892] pci 0000:00:1f.2: PME# supported from D3hot 
[ 0.194957] pci 0000:00:1f.3: reg 20 io port: [0x500-0x51f] 
[ 0.195097] pci 0000:01:00.0: reg 24 io port: [0x9000-0x907f] 
[ 0.195212] pci 0000:00:1c.0: bridge io port: [0x9000-0x9fff] 
[ 0.195287] pci 0000:02:05.0: reg 10 io port: [0xa000-0xa0ff] 
[ 0.195360] pci 0000:02:05.0: supports D1 D2
[ 0.195367] pci 0000:02:05.0: PME# supported from D1 D2 D3hot D3cold 
[ 0.195437] pci 0000:00:1e.0: bridge io port: [0xa000-0xafff] 
[ 0.224801] system 00:01: ioport range 0x4d0-0x4d1 has been reserved 
[ 0.224807] system 00:01: ioport range 0x290-0x29f has been reserved 
[ 0.224813] system 00:01: ioport range 0x800-0x87f has been reserved 
[ 0.224819] system 00:01: ioport range 0x880-0x88f has been reserved 
[ 0.224836] system 00:0b: ioport range 0x400-0x4bf could not be reserved 
[ 0.279897] pcieport 0000:00:1c.0: irq 24 for MSI/MSI-X – Raven Aug 27 at 0:42 edit 
[ 0.195367] pci 0000:02:05.0: PME# supported from D1 D2 D3hot D3cold 
[ 0.195437] pci 0000:00:1e.0: bridge io port: [0xa000-0xafff] 
[ 0.224801] system 00:01: ioport range 0x4d0-0x4d1 has been reserved 
[ 0.224807] system 00:01: ioport range 0x290-0x29f has been reserved 
[ 0.224813] system 00:01: ioport range 0x800-0x87f has been reserved 
[ 0.224819] system 00:01: ioport range 0x880-0x88f has been reserved 
[ 0.224836] system 00:0b: ioport range 0x400-0x4bf could not be reserved 
[ 0.279897] pcieport 0000:00:1c.0: irq 24 for MSI/MSI-X
[ 0.279910] pcieport 0000:00:1c.0: setting latency timer to 64 
[ 0.287215] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled 
[ 0.291459] input: Macintosh mouse button emulation as /devices/virtual/input/input2 
[ 0.299338] ehci_hcd 0000:00:1d.7: cache line size of 128 is not supported 
[ 0.346769] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00 
[ 0.347042] hub 1-0:1.0: 8 ports detected [ 0.347617] hub 2-0:1.0: 2 ports detected 
[ 0.348036] hub 3-0:1.0: 2 ports detected [ 0.348459] hub 4-0:1.0: 2 ports detected 
[ 0.348891] hub 5-0:1.0: 2 ports detecte – Raven Aug 27 at 0:43 edit 
[ 0.279910] pcieport 0000:00:1c.0: setting latency timer to 64 
[ 0.287215] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled 
[ 0.291459] input: Macintosh mouse button emulation as /devices/virtual/input/input2 
[ 0.299338] ehci_hcd 0000:00:1d.7: cache line size of 128 is not supported 
[ 0.346769] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00 
[ 0.347042] hub 1-0:1.0: 8 ports detected 
[ 0.347617] hub 2-0:1.0: 2 ports detected 
[ 0.348036] hub 3-0:1.0: 2 ports detected 
[ 0.348459] hub 4-0:1.0: 2 ports detected 
[ 0.348891] hub 5-0:1.0: 2 ports detected   
[ 0.349073] PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp 
[ 0.349998] serio: i8042 KBD port at 0x60,0x64 irq 1 
[ 0.350404] rtc_cmos 00:03: RTC can wake from S4 [ 0.350475] rtc_cmos 00:03: rtc core: registered rtc_cmos as rtc0 
[ 0.350506] rtc0: alarms up to one month, 242 bytes nvram, hpet irqs – Raven Aug 27 at 0:43 edit 
[ 0.349073] PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp 
[ 0.349998] serio: i8042 KBD port at 0x60,0x64 irq 1 [ 0.350404] rtc_cmos 00:03: RTC can wake from S4 
[ 0.350475] rtc_cmos 00:03: rtc core: registered rtc_cmos as rtc0 
[ 0.350506] rtc0: alarms up to one month, 242 bytes nvram, hpet irqs
[ 0.355364] Using IPI No-Shortcut mode 
[ 0.356078] rtc_cmos 00:03: setting system clock to 2010-08-27 10:13:42 UTC (1282904022) [ 0.763804] sd 3:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA 
[ 0.763811] sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA 
[ 0.826587] udev: starting version 151 
[ 0.860561] hub 1-1:1.0: 4 ports detected 
[ 1.116873] USB Mass Storage support registered. 
[ 2.734937] hub 3-2:1.0: 4 ports detected 
[ 13.477205] udev: starting version 151 – Raven Aug 27 at 0:43 edit 
[ 0.355364] Using IPI No-Shortcut mode
[ 0.356078] rtc_cmos 00:03: setting system clock to 2010-08-27 10:13:42 UTC (1282904022)
[ 0.763804] sd 3:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 0.763811] sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 0.826587] udev: starting version 151
[ 0.860561] hub 1-1:1.0: 4 ports detected
[ 1.116873] USB Mass Storage support registered.
[ 2.734937] hub 3-2:1.0: 4 ports detected
[ 13.477205] udev: starting version 151
[ 13.686799] Linux agpgart interface v0.103
[ 13.953260] USB Serial support registered for generic
[ 13.958045] USB Serial support registered for GSM modem (1-port)
[ 13.973144] option 3-2.4:1.0: GSM modem (1-port) converter detected
[ 13.973594] usb 3-2.4: GSM modem (1-port) converter now attached to ttyUSB0
[ 13.973643] option 3-2.4:1.1: GSM modem (1-port) converter detected
[ 13.973747] usb 3-2.4: GSM modem (1-port) converter now attached to ttyUSB1
[ 13.686799] Linux agpgart interface v0.103
[ 13.953260] USB Serial support registered for generic
[ 13.958045] USB Serial support registered for GSM modem (1-port)
[ 13.973144] option 3-2.4:1.0: GSM modem (1-port) converter detected
[ 13.973594] usb 3-2.4: GSM modem (1-port) converter now attached to ttyUSB0
[ 13.973643] option 3-2.4:1.1: GSM modem (1-port) converter detected
[ 13.973747] usb 3-2.4: GSM modem (1-port) converter now attached to ttyUSB1
[ 13.973783] option 3-2.4:1.2: GSM modem (1-port) converter detected
[ 13.973908] usb 3-2.4: GSM modem (1-port) converter now attached to ttyUSB2
[ 14.068472] parport_pc 00:09: reported by Plug and Play ACPI
[ 14.068526] parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
[ 14.172348] lp0: using parport0 (interrupt-driven).
[ 16.456225] ppdev: user-space parallel port driver
russell@ubuntu:~$
share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 17:05

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

We are going to need more info to be able to help you. Like what type of wireless adapter are you using and what Ubuntu version are you using.

------ TRY 1: Failed

One generic tip is to System->Administration->Hardware Drivers. Maybe you need to download some driver. If your wireless card is listed in the window that opens, please click the button to install it's drivers.

But with so little info this is just a blind shot.

------ TRY 2: Failed

Thank you for all the info. Belkin is famous for using different chipsets in the same product, F5D7050 uses at least 3 different chipsets. Anyway, the window's driver filenames are gold. Your card is likely a rt2500.

The most common problem with this card is that multiples modules (kinda of windows drivers) try to use it, conflicting. You will need to do some file-editing-foo to solve it.

Press ALT+F2 or open a console. Type or copy/paste:

gksudo gedit /etc/modprobe.d/blacklist.conf 

Now at the end of the file append this two lines:

blacklist rt2500usb
blacklist rt2800usb

And reboot, if you are lucky it should be working after the reboot. If not, there are probably other kind of conflict, edit the file again, remove the lines, reboot, open a console and type:

dmesg | grep rt

Seems like no rt* modules is beign loaded. So it's my mistake. But if the wifi works (at times) it must be loading some drivers and windows drivers make it look like a rt2500...

----------- TRY 3: Never Tested

Another shot. There are some reports of disconnections with people using rt* chipsets with the current kernel. You can try to update your kernel.

You need to add this PPA to your software sources. In the PPA page you can found detailed instructions about how to add them, but in short, you must open System->Administration->Sotware Sources, click on the "Other Software" tab, click add and write there ppa:kernel-ppa/ppa.

Afterwards you need to install the updated kernel. The easiest way is to open the Ubuntu Software Center, under get software select the new PPA and in the right panel choose to install the Complete Generic Linux Kernel, if you see two choose the one without pae in its name.

Reboot and let's hope that the linux gods will smile on us this time.

If you have any problem with the new kernel, you press ESC while booting for a menu that will let you boot from the old one.

----------- RESOLUTION: OP just build another adapter

Usually the easiest solution.

share|improve this answer
    
Thank you for the response. The Ubuntu version is 10.04 LTS The wireless adaptor is a Belkin wireless 802.11g USB network adaptor. The same adaptor works fine on windows as you can see by my access here Sometimes it will connect then drop out other times nothing at all. I will swap over to Ubuntu now and try your generic tip.. Thank you –  Raven Aug 26 '10 at 1:19
    
Tried the generic went to system-administration then hardware drivers the system went searching and came back with 2 drivers both for my Nvidia card the one recommended was active. There were no other drivers listed. –  Raven Aug 26 '10 at 1:39
    
There too many Belkin usb adaptors. We need the exact model, more exactly the chipset that it uses. If you boot Ubuntu, insert the adaptor, open the terminal and type -sudo lsusb- without the -s. The computer will generate a list with the ids of all your usb devices. Please post back the wireless adapter one. –  Javier Rivera Aug 26 '10 at 7:53
    
ok thank you...here we go...Firstly the box saysPart #F5D7050au version 2 Ubuntu when I run the command you suggest replies with Belkin Components F5D7050 Version 1000 WiFi –  Raven Aug 26 '10 at 8:56
    
I looked on the installation disk that came with the USB wireless device and it has a folder for drivers there are 4 files in this folder that I can see in windows rt25u98 system file and rt2500usb security catalog and rt2500usb setup information and finally rt2500usb system file...........I gather these wont work for Ubuntu? –  Raven Aug 26 '10 at 9:21