Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since at least Jaunty, I've tried to get my wife's 3G USB modem to work on Ubuntu, always with the same result - instant, complete system freeze.

I've tried installing`wvdial and usb-modeswitch, I've read tons of documentation but it gets quite disjointed from one release to the next, nothing works. I can't run lsusb because the system hangs immediately.

I'm using Lucid and it's a Rogers "Rocket Stick" (in Canada)

share|improve this question
    
Does your system freeze when running lsusb even when the modem.is not plunged in? If so you probably need to debug your usb controller first. –  user1362567 Sep 22 '10 at 9:03
    
No, it freezes when I plug the modem in. Instantly, no chance to run lsusb or anything else. –  stone1343 Oct 9 '10 at 23:52

3 Answers 3

Try this “automagic” script: sakis3g. No need to install anything, just run the script; it will guide you through menus.

After you make it work, you can create a small script calling the sakis3g-script having set up some environment variables for your convenience. Here follows mine:

export BAUD=MAX MODEM=1bbb:0000 APN=3g-internet SIM_PIN=1234
(sakis3g-script helper&)&

The $MODEM is the vendor-id:product-id code so I don't have to select it everytime I start the sakis3g-script; $APN is your provider's suggested login name; the SIM_PIN is rather obvious.

See also that question in SuperUser.

share|improve this answer

The first stop should be, to figure out which chipset the stick is using and which driver is loaded (that causes the freeze). You could try running "sudo dmesg | tail -f" in a terminal while plugging in the stick. That might also help identifying the problem.

share|improve this answer
    
Except I can't run anything because the system freezes right away. –  stone1343 Oct 9 '10 at 23:54

The real answer is to start with a supported device. See http://en.wikipedia.org/wiki/NetworkManager for a list of working devices.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.