Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed fresh Ubuntu 13.04 on my Lenovo Ideapad z570, alongside Windows 7

Grub2 has replaced Windows mbr, so I get presented with a menu, when I boot - when I select Ubuntu - the screen stays blank (purple screen) - pressing any key have no effect.

I can boot however from a USB (in fact this is how I installed it)

below is laptop configuration:

Computer                                                                        
Computer Brand Name:                                                            LENOVO Ideapad Z570

Motherboard                                                                     
Motherboard Model:                                                              LENOVO Emerald Lake
Motherboard Chipset:                                                            Intel HM65 (Cougar Point) [B3]

BIOS                                                                            
BIOS Manufacturer:                                                              Phoenix Technologies
BIOS Date:                                                                      10/21/2011
BIOS Version:                                                                   45CN38WW
EFI BIOS:                                                                       Capable

I also have Samsung 840 pro ssd installed

share|improve this question
    
Enter the edit mode at the GRUB menu and remove quiet splash from the kernel line to see whats really going on. Make a screenshot if there is additional information and add it to your question. –  LiveWireBT Jun 15 '13 at 11:44
    
when I try to boot in recovery mode the only line I get on screen is "loading kernel 3.xx". From what I gathered from other threads - it has something to do with EFI vs BIOS boot. –  ArtDeineka Jun 15 '13 at 18:19
    
Then please check if the settings in UEFI firmwware are set to maximum compatibility. It should be the equal to my T530. Under startup you should find an option called UEFI/Legacy Boot set it to Both, below should be an option called CSM Support set this to Yes. –  LiveWireBT Jun 15 '13 at 21:16
    
My BIOS doesn't have this option (this is the latest bios vesrion for this model according to Lenovo.com), here's what Boot menu looks like i.imgbox.com/abkPxYfL.jpg –  ArtDeineka Jun 16 '13 at 18:39
    
Sorry, seems like they do use a different firmware for the ideapads. What is your setup now? Windows is installed on the HDD and Ubuntu on the SSD, GRUB MBR bootloader is installed to SSD? It looks like GRUB cannot find the filesystem with the kernel image (probably because the usb stick was detected as first disk - though GRUBs configuration should still be able to search for the proper UUID and I wasn't able to reproduce this behaviour). Could you take a photo of the GRUB entry in edit mode? –  LiveWireBT Jun 17 '13 at 1:02
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.