Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Right now all we can do is set the TV to 1280x768 instead of its native resolution of 1360x768. Setting it to its native resolution gives you a screen with a large portion of the left side of the screen cut off. We've tried everything with the TV so now we're turning to the innards of Ubuntu in hopes of fixing this. The computer is using an NVIDIA GeForce GT240. This is its current xorg.conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Fri Apr  9 10:35:18 UTC 2010


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: builtin, VertRefresh source: builtin
   # HorizSync       28.0 - 55.0
    # VertRefresh     43.0 - 72.0
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-0"
    HorizSync       28.0 - 55.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 6600"
EndSection

Section "Screen"

# Removed Option "metamodes" "1360x768 +0+0; 800x600 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1360x768 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this question

1 Answer 1

Televisions do not have a native resolution of 768 lines. Standard def is 540, and HD is either 720 or 1080. It probably expects 1280 x 768 from a VGA connector and scales it. When you give it the wider resolution, it scales wider than the TV. Stick to the resolution that works.

share|improve this answer
    
I should probably add that I actually got an older computer working on the same TV with the same cable... I'm pretty sure the solution had something to do with it's xorg.conf so I copied it from the old computer to this new one. It didn't work. :( –  RPG Master Mar 18 '11 at 0:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.