Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently, after a system update, my wireless network has being stopping to transfer data from some irregular time intervals that vary from 30 seconds to 20 minutes, and every time I need to plug off and then on the wireless adapter. I tried to update again the system several times and nothing changed.

Note that the network doesn't disconnect, it remains connected although no data is exchanged, no uploads or downloads. Reconnecting the wireless adapter in most of the times works, although sometimes when I reconnect it my WiFi network isn't listed, then I have to click on "Connect to a Hidden Wireless Network..." and then I will connect to my network.

Using ping (ping 8.8.8.8) to see what happens, when data transfer stops I receive this message:

ping: sendmsg: No buffer space available

Searching for solutions relating to this message I found that it can be the wireless router, so I reseted it and configured everything. The problem persisted.

So I found out that a solution for this is to increase buffer size with this command:

# echo 83886080 > /proc/sys/net/core/wmem_max

I did that and it seemed to resolve the problem, although after a day it came back. I also noticed that when the wireless is crappy, like stopping connection in 20 to 20 seconds, when I click to shutdown the PC it doesn't shutdown, it hangs on the purple screen written Ubuntu and then I have to hold power button in order to restart the PC.

I already tried using the wireless adapter in Windows 8, in this PC, and it works perfectly, already tried it in a notebook, both, Ubuntu 13.04 and Windows 8 worked perfectly.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.