Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

when I run sudo apt-get update command on terminal it tells the following error.

W: GPG error: http://ppa.launchpad.net precise Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A777609328949509

to fix this, I also run the following command.

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A777609328949509

but everything went into vein. Plzzz help.

share|improve this question
    
Please can you clarify exactly what happens when you run apt-key? What does it output? –  David Edwards Jun 14 '13 at 8:02
    
when i run the apt-key it gives the following response. Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.9d2ZwwwhHH --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys A777609328949509 gpg: requesting key 28949509 from hkp server keyserver.ubuntu.com gpgkeys: key A777609328949509 not found on keyserver gpg: no valid OpenPGP data found. gpg: Total number processed: 0 –  user167118 Jun 14 '13 at 8:33
    
Can you try running sudo apt-key update and see if that makes a difference? –  David Edwards Jun 14 '13 at 8:42
    
sudo apt-key update not helping me... :'( –  user167118 Jun 14 '13 at 8:50
    
The error message doesn't mention a connection problem, but I wonder if you are behind a proxy or firewall. Please can you try running sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys A777609328949509? –  David Edwards Jun 14 '13 at 9:19
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.