Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two external HDD attached to my PC which start normally when I turn on the PC. When I restart (after an update for example) one of the two drives does not mount, always the same drive. It has always acted like this but I was wondering was there a way to fix this.

Currently running Ubuntu 10.10, let me know if more information would help

share|improve this question
    
Please post an output of your fstab file: cat /etc/ftab –  mount.cifs Mar 17 '11 at 17:46
    
They mount automatically or you added them manually to /etc/fstab? –  arrange Mar 17 '11 at 17:48
    
I have never needed to mount manually, just plugged them into the PC –  Victor9098 Mar 17 '11 at 17:58
    
This is my /etc/fstab –  Victor9098 Mar 17 '11 at 18:00
    
# /etc/fstab: static file system information. # # Use 'blkid -o value -s UUID' to print the universally unique identifier # for a device; this may be used with UUID= as a more robust way to name # devices that works even if disks are added and removed. See fstab(5). # –  Victor9098 Mar 17 '11 at 18:04

1 Answer 1

Add the disk to the fstab configuration file.

Check following page:

https://help.ubuntu.com/community/fstab

share|improve this answer
    
Thanks for that but when I tried adding both drives disappeared at start-up and half of docky disappeared for some reason. Undid the changes and everything back to normal. Have tried a few variations of the command line but no joy, really a novice with that end of things. The 2nd HDD is not listed in Fstab but it mounts and runs fine when I restart, but adding the other HDD gets rid of both! Will keep poking around –  Victor9098 Mar 17 '11 at 19:37
    
OK, looks like I broke something now I can not even mount the drive: "Error mounting: mount: wrong fs type, bad option, bad superblock on /dev/sdg1, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so" –  Victor9098 Mar 17 '11 at 19:52
    
I think I have fixed everything now. Added both drives and all the errors have gone away. But when I restart I get a message on the screen saying the 'problem' drive is not yet ready or mounted and to either to skip or mount manually. I skipped. Shutdown, started up and logged in fine. So the restart process is still throwing up issues –  Victor9098 Mar 17 '11 at 23:28
    
link it broken. –  guy mograbi Jun 10 '13 at 12:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.