Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I've got a new laptop with pre-installed windows 8 and since the beginning of the week I've been trying to install Ubuntu 12.04 without success.

Today, after turning off UEFI (using "Compatibility Support Module" or simply "CSM") I managed to install Ubuntu using this URL found on Ubuntu official website:

I've run the boot-repair tool while running Linux. Tried to use the automatic repair and everything went fine and I've restarted the machine.

Then I turned UEFI on again and the first surprise was: the initial screen was not Windows boot loader any more but grub; I really don't want that.

And the second surprise: although I can boot Windows (I am using it right now) , I can't initiate Linux. After choosing one of Linux options in the grub screen, absolutely nothing happens.

Here's the link generated by the boot repair application:

If possible I would really appreciate some help in (1) setting windows boot loader screen as the default and (2) install and run Linux (with dual boot windows) with UEFI and FastBoot on on this machine.

If you have a tutorial that you think I can follow to solve these problems I would also be very pleased.

Update June, 16th
Hello, I appreciate your answer. In fact, first, I've installed Ubuntu with Uefi turned off and everything worked well. Then, while using Ubuntu, I've followed the steps on the link that I've pasted on the last post in order to convert the Ubuntu installation from legacy to Uefi mode. After I did that, the system couldn't be loaded any more. When I turn on my notebook, the first screen that cames to me is the Grub2 screen. In that screen I have two options for ubuntu, and 4 for windows. I can load windows with no problems, but when I try to load Ubuntu (recovery or normal mode), the system simply does not respond. It shows me just a black screen and then I have to restart the notebook through the power button. I've tried loading ubuntu this way with and without uefi and I have the same result.The point is: I want now to uninstall linux and clean the partition that I've reserved to the installation in order to install it again and use the os with legacy mod. But how can I do that without loading the os? Thank your very much, Vitor.

share|improve this question

marked as duplicate by Mitch, Radu Rădeanu, Eric Carvalho, Luis Alvarado Jun 17 '13 at 2:44

This question was marked as an exact duplicate of an existing question.

Unfortunately so far I have not seen anyone install a GNU / Linux with UEFI so you must configure your BIOS to legacy that way you can access the GRUB, I hope you're looking for

share|improve this answer

I don't know how to get Windows' boot loader to redirect to a Linux boot loader in EFI mode. In fact, I don't believe it's possible. Thus, part of what you're asking for isn't possible, or at least, I don't know how to do it. You'll have to accept using something other than the Windows boot loader as the primary boot program. That said, you should be able to set whatever boot manager you use to run Windows as the default OS.

Saying "I can't initiate Linux" is insufficiently clear; you don't say what happens when you try to launch Linux. Any error messages -- or lack of same -- are important in diagnosing the nature of the problem. Absent that information, we're all left guessing about the nature of the problem.

Personally, I'm not a fan of GRUB 2. Thus, between that and the lack of information on how GRUB is failing, my recommendation is to bypass it:

  1. Re-run Boot Repair, but this time, select the "Advanced Options" item, click "Restore EFI Backups" from the resulting dialog box, and click "Apply." This should undo most of Boot Repair's changes, which will make it easier to make subsequent changes.
  2. If you've not already done so, use the firmware setup utility to disable Secure Boot, which causes more problems than it's worth at the moment. (Unfortunately, how you disable Secure Boot varies from one firmware to another, so I can't describe this step in more detail.)
  3. Boot to Windows.
  4. Download the binary .zip file for rEFInd.
  5. Install rEFInd from Windows, as described in its documentation.
  6. Ensure that the EFI filesystem driver for ext4fs is installed. It should be in the drivers_x64 subdirectory of the rEFInd installation on the ESP. You can optionally delete the other drivers.
  7. Reboot. rEFInd should appear.
  8. Highlight one of the entries for Linux that refers to a file called vmlinuz-{version}, where {version} is a version number.
  9. Press F2 or Insert twice. This should open a simple line editor.
  10. Add ro root=/dev/sda8 to the kernel options in the line editor.
  11. Press Enter. Linux should boot.
  12. In Linux, access the files from the rEFInd .zip file.
  13. Run the script, as in sudo ./, typed from the directory in which the file exists. This should create a file called /boot/refind_linux.conf. This file will obviate the need to edit the boot options (steps 9-10, above) on subsequent boots.
  14. Optionally edit /boot/efi/EFI/refind/refind.conf and change any options you like to trim unwanted boot entries (using dont_scan_files or dont_scan_dirs), to change the default boot option (using default_selection), etc.

If all goes well, your system will boot into rEFInd on subsequent boots, and from there you'll be able to launch either Windows or Linux. There are, however, a number of things that can go wrong with this procedure, so you may need to do some troubleshooting at one step or another.

share|improve this answer
Thx for your answer. Please refer to the original message, I've made some updates on the bottom of the text. I would appreciate any help. Regards, Vitor. – Vitor Miranda De Oliveira Jun 17 '13 at 2:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.