Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run ruby via rbenv on Ubuntu server for my personal projects and everything works fine. At work, however, I am trying to install the same configuration with rbenv on a pre-installed version of Ubuntu server (VPS) and I get 'permission denied' every time I do something. This organization takes every precaution when securing servers, so I am assuming the permission denied errors are coming from something they have locked down.

My user account does have sudo rights and I have to use this every time I run any command which will make a change. For example, on a default Ubuntu install I can do 'mkdir aaa' and it works just fine. However, on the work VPS, I get permission denied and I have to run 'sudo mkdir aaa' to make the directory.

Why is this? What can I do to make this run normally??

share|improve this question
1  
Do you have access to the /etc/sudoers for that work VPS? Just check whether there are any restrictions imposed on a user_group or different permissions defined. As you mentioned organization takes every precaution when securing servers, i would suggest you request to have an explicit access permission to run things normally raising no alarms :-). –  karan Jun 14 '13 at 11:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.