Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm installing the vagrant with sudo apt-get install. This error I got:

...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Setting up virtualbox (4.1.18-dfsg-1ubuntu1.2) ...
 * Stopping VirtualBox kernel modules                                   [ OK ] 
 * Starting VirtualBox kernel modules
 * No suitable module for running kernel found                          [fail]
invoke-rc.d: initscript virtualbox, action "restart" failed.
Setting up vagrant (1.0.3-1) ...
Processing triggers for ureadahead ...
Setting up virtualbox-dkms (4.1.18-dfsg-1ubuntu1.2) ...
Loading new virtualbox-4.1.18 DKMS files...
First Installation: checking all kernels...
Building only for 3.8.0-030800-generic
Building initial module for 3.8.0-030800-generic
ERROR (dkms apport): kernel package linux-headers-3.8.0-030800-generic is not supported
Error! Bad return status for module build on kernel: 3.8.0-030800-generic (x86_64)
Consult /var/lib/dkms/virtualbox/4.1.18/build/make.log for more information.
 * Stopping VirtualBox kernel modules                                   [ OK ] 
 * Starting VirtualBox kernel modules
 * No suitable module for running kernel found                          [fail]
invoke-rc.d: initscript virtualbox, action "restart" failed.
Setting up virtualbox-qt (4.1.18-dfsg-1ubuntu1.2) ...
Processing triggers for menu ...

Ubuntu 12.10

$ uname -a
Linux 3.8.0-030800-generic #201302181935 SMP Tue Feb 19 00:36:19 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
share|improve this question
    
Have you consulted /var/lib/dkms/virtualbox/4.1.18/build/make.log for more information as suggested by the error message? –  David Edwards Jun 14 '13 at 10:26
    
It seems it has nothing to do with Vagrant. 3.8.0-030800-generic is not in Ubuntu 12.10 repository, but is in a PPA. It is not supported by VirtualBox. 12.10 has 3.5, do you have a real need for 3.8? You should try to remove the custom kernel, install the one provided by Ubuntu, boot with this one, and reinstall VirtualBox. –  ignis Jun 14 '13 at 13:46
    
I'm owner of Sony Vaio Z, and I had issues to install Ubuntu in my Notebook, I found some solutions with custom kernel in the net. Don't sure if my system will run when I downgrade the kernel. Any other suggestion? –  Kostanos Jun 14 '13 at 14:14

1 Answer 1

If the version of VirtualBox in the Ubuntu 12.10 repository does not support kernel version 3.8, you could try installing the most recent version of VirtualBox using the Oracle repository instead. More recent version of VrtualBox support more recent kernels.

Instructions for adding their repository are here:

https://www.virtualbox.org/wiki/Linux_Downloads

Note that you might need to uninstall your current VirtualBox and Vagrant packages first. Note also that the Oracle VirtualBox packages have different names.

Then, when installing Vagrant you will need to stop it from removing your new version of VirtualBox. You could try doing that by installing Vagrant from the Ubuntu repository but adding --no-install-recommends when you run apt-get, or you could try downloading and installing Vagrant direct from their website:

http://downloads.vagrantup.com/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.