Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a problem with a friend's old external hard drive. The hard drive (1.5TB WD Caviar Green) isn't detected by any computer regardless of the OS installed.

So I disassembled the hard drive from the external case and plugged into my PC (I had to remove my normal hard drive in order to do so). I then tried to install Puppy Linux, which didn't work, because of some problems partitioning the drive (something like Error writing to /dev/sdb: Input/output error or similar).

That's why I decided to give the Gparted live disk a try, which didn't detect the hard drive at all.

Later on I burned an Ubuntu 13.04 64-bit installation DVD and tried to install it, creating only Read/Write errors similar to those I got when trying to install Puppy Linux.

Then I decided to just launch Ubuntu as a live CD and ran Gparted again, which surprisingly detected the hard drive, but failed to partition it, because of a missing partition table. Unfortunately neither Gparted nor the Disk Utility were able to create it.

Do I have a chance to create this partition table and partition the drive, or is it just broken?

share|improve this question
    
I think the hdd is fried, if it gives you i/o errors. –  Yet Another User Jun 13 '13 at 15:17
    
Yet_Another_User could be right, but did you try to partition it while it was unmounted. If it is mounted, you will most likely get errors. –  Max Tither Jun 13 '13 at 15:38
    
When unmounted gparted doesn't detect the hdd. –  Jonas Jun 13 '13 at 16:09
add comment

1 Answer

Try using Disk Utility to check the drive's SMART information. You can also run some low-level tests on the disk from here which should help confirm whether the drive is faulty.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.