Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got this error during installation.

The installer encountered an error copying files to the hard disk: [Errno 5] Input/output error This is often due to a faulty CD/DVD disk or drive, or a faulty hard disk. It may help to clean the CD/DVD, to burn the CD/DVD at a lower speed, to clean the CD/DVD drive lens (cleaning kits are often available from electronics suppliers), to check whether the hard disk is old and in need of replacement, or to move the system to a cooler environment.

How can I fix this and what does it mean specifically? I'm installing via USB so it can't be the CD. the laptop is recent so it cant be an old HD.

share|improve this question
What do mean during installation? it seems you are burning a CD/DVD, if you are, please tell us what kind of burning software you are using. anyway try burner at a slower speed. – Achu Mar 17 '11 at 14:34
no it's on usb. this problem occured during installation, after setting partitions and specifying location etc etc.. when they give the slideshow and say take a look at it while the installation is done, this is when i got this error. – Nadim Hachem Mar 17 '11 at 14:36
if that so, the error message explain the problem. may be your hard disc is full, make sure you have enough space on your hard disc. if you have enough space try installing from another source may be from CD/DVD. – Achu Mar 17 '11 at 14:50
possible duplicate of "errno 5 - input/output error" when trying to install – Eric Carvalho Aug 19 '15 at 12:34

10 Answers 10

Either the cd or your hard disk is bad. You can check the CD with the "Check disc for defects" option when you boot it up. You can check your hard disk by opening Administration->Disk Utility and checking the SMART attributes. Look for non zero values for reallocated, pending, and offline_uncorrectable sectors. Then you might want to run the long self test.

share|improve this answer

I just had the same problem today. I had inadvertently interrupted an install on my netbook, and it was neither installing nor booting into the OS. I tried using multiple USB drives and multiple *buntu distros to try to circumvent things, which didn't work. I was using the USB installer from, which I've used before and had success with. To be thorough in my troubleshooting, I downloaded the USB installer on another computer, and it still didn't help. Eventually, I tried a Windows USB installer to put a copy of Win7 on, which worked (strangely). I then immediately overwrote Windows with MeeGo, which I'm currently noodling around with. Roundabout, I know, and I still don't know WHY it worked, but there you go.

share|improve this answer
edit I have since tried the UNetBootin utility, whereas before I was using the Universal USB installer from It looks like, in my case, my netbook just wouldn't play nicely with the Universal Installer, since every other installer I've used has worked fine. – Brian W Jan 10 '12 at 16:06

This problem drove me crazy for 2 weeks on and off. I have finally found out what the problem is and I registered just to share my conclusion to help others because this is a very misleading error to a lot of us.

I have 2 laptops and I tried to install BackTrack, BackBox, Ubuntu, etc.. all failed on one laptop and I couldn't understand why, I was installing from a live USB and it was still complaining about the CD/DVD error!! what the hell, it does not make any sense.

I opened up my laptop, I completely removed the CD/DVD and tried again and it still failed. I opened up my laptop hoping my final resolution was to just remove a 2GB ram but to my luck, the laptop had just one 4GB RAM stick, so that trick would not work.

I came to the wrong conclusion that others came to as well and that is perhaps the linux OS is just not compatible with all hardware out there and in my mind I started to blame developers even though I am one.

Why this problem is a misleading one? Because:

  1. You can go into your bios and detect that you have the correct size of ram (4GB) and also boot windows 7/8 and use it just fine, no problems at all, so why should Linux complain !, also in my case this was a brand new laptop as well.!!

  2. There is a large number of us users that are actually experiencing this problem, so this could lead to the understanding that it is actually the OS and not our hardware. However, until you restart your machine and go into “Diagnostics” you won’t know that there is actually a problem with your ram, Its much quicker than using memtest to detect if there is indeed an issue.

This leads me to believe that linux is actually so good that it does a proper test of the CRC of your ram as it tries to install itself and will fail if there is something wrong with the ram, a bit harsh though.

Having said that, linux developers still need to change the error message to help the users understand clearly that there is a ram issue as oppose to a missleading "CD / DVD error" but also there should still be a way to bypass the error and continue the installation of the OS because we know that windows can operate just fine on the faulty ram.

I replaced the faulty RAM and it worked just fine. I really hope this helps people to cut to the chase.

When people are suggesting to remove 1 ram and got it to work, they most definatly removed the faulty ram, its not because it was a trick to remove one and keep the other to fool the OS.


share|improve this answer
Same problem here. Tried installing 12.04 LTS on an old Optiplex 280 and this error kept coming up. I popped in a "Ultimate Boot CD" and test the hard drive but it was fine. Then I found this post, so I tested the memory. Sure enough I had a bad stick of RAM. Thanks for the diagnosis! – TheRandomSuit Apr 17 '13 at 1:12

It's not clear where the error comes from (USB, drive?). You can

  • have a look at the disk's SMART data via Palimpsest Disk Utility or
  • when this problem occurs, change the console by pressing Ctrl+Alt+F4 (I'm not sure it is F4, could be F3 or other, you can try more). There you should be able to see more information about the error, note it down or take a photo of the screen
share|improve this answer

People in the net seems to have experienced this in the past, which seems to be to a hardware related issue.

The majority of the cases points to "Change the CD (hardware and disc brand)" and/or "Change the amount of memory used for the install process (probably a memory bank corrupted or something)".

Somehow you can give a try to this and inform us.


Good luck!

share|improve this answer

I had this error, when it was copying files it said :

The installer encountered an error copying files to the hard disk: [Errno 5] Input/output error This is often due to a faulty CD/DVD disk or drive, or a faulty hard disk. It may help to clean the CD/DVD, to burn the CD/DVD at a lower speed, to clean the CD/DVD drive lens (cleaning kits are often available from electronics suppliers), to check whether the hard disk is old and in need of replacement, or to move the system to a cooler environment.

The memory (RAM) on my computer was bad (11 years old). After replacing it the OS installed fine.

share|improve this answer

I find this error both strange and, as any error, annoying. It's happening to me both with Ubuntu and Elementary OS.

I've tried with several USB Drives and several DVDs. HD right? Wrong! Second HD and the same problem prevails witch is strange because Fedora and Windows install with no problems what so ever!

If anyone finds a workaround this issue, PLEASE share the information!

------------ EDIT ------------

Believe it or not, after 2 days of trying, it worked! How? Well, I'm on a Pentium 4 HT and apparently all I had to do to get it to install was going into the BIOS and disable the Hyper-threading for the installation. After that, turned it back on and booted fine!

share|improve this answer

How I fix this error in a simple way: after opening the Ubuntu CD / DVD install menu, start Ubuntu as Test / Trial, without installing on harddisk. When the O.S. is ready to use, just install the Ubuntu from the icon / shortcut in the menu sidebar or desktop itself.

Hope it works for you!

share|improve this answer

I had the same problem and same error message and trouble-shooted for two days. I installed using a thumbdrive on a an old DIY system running C2D E6420 on a Asus P5Q SE/R motherboard with my SATA running in IDE mode.

At first I thought it was my drive, changed it, no luck. Changed my startup disk creator from Rufus to Pendrivelinux. Changed 14.04 LTS to 15.10. But the error message kept coming back. Then I read the post above by Will Smith and changed my 2 x 2 GB DDR3 667 to a single 2 GB DDR2 800 and it finally installed all the way without any hiccups.

share|improve this answer

What is this stuff with blaming everything that simply does not work on "faulty hardware"?

I've seen this message now on 3 machines and from 4 different cds - all burnt at very low speed! Apparently it's just a standard message that pops up whenever anything goes wrong... just like MS Word back in 1991!

The solution that worked for me: After the failure, ubuntu started a desktop session. Clicking "install Ubuntu.." wouldn't do anything, but bringing up a terminal (ctrl-alt-t) and starting ubiquity by hand re-ran the installer, and this time each and every failed file were clearly shown, plus there is option to "skip" and continue the installation process.

Once done, repair the installation and along you go!

share|improve this answer
Hi buddy, can you further explain this in a way that it is easier to understand. Specially for users new to Ubuntu. – Luis Alvarado Mar 12 '13 at 23:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.