Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using xubuntu "precise".

I have set up my preferred applications (Settings/Preferred-Applications or $ exo-preferred-applications):

  • web browser: chromium
  • mail reader: thunderbird
  • file manager: thunar
  • terminal emulator: xfce4-terminal

However, some programs have their own ideas:

  • clicking the terminal icon in the xfce panel opens xfce4-terminal but Thunar's "open terminal here" opens NextStep terminal.
  • clicking a link in thunderbird or the terminal opens it in chromium, clicking a link in a PDF in evince fails with "Failed to execute child process "/opt/google/chrome/google-chrome" (No such file or directory)". Clicking a link in OpenOffice opens firefox whereas alpine prefers to open links in epiphany.
  • "Open containing folder" in evince fails with "Failed to execute default file manager - Failed to execute child process "/usr/bin/Thunar" (Permission denied)." (Doubly odd as said application exists and runs fine on the command line.) Other programs prefer to launch nautilus instead.

What settings to I have to set so that every application that needs a browser/terminal/file manager uses the correct one? Getting evince to open hyperlinks correctly and Thunar my xfce terminal are my priorities, everything else would be nice.

share|improve this question
add comment

1 Answer 1

You may have to change "desktop specific" applications (e.g. Nautilus to Gnome, Dolphin to KDE, ...) via the desktop specific control applications.

So for Gnome use gnome-control-center and for KDE systemsettings and set the default applications.

share|improve this answer
    
Ok, after setting chromium as default in gnome-control-center, ckicling a link in evince fails with /usr/lib/chromium-browser/chromium-browser-sandbox: error while loading shared libraries: libpthread.so.0: failed to map segment from shared object: Permission denied. Chromium is installed and works fine. –  Bristol Jun 13 '13 at 10:27
    
There is some bug: bugs.launchpad.net/ubuntu/+source/apparmor/+bug/964510 –  Manuel Jun 13 '13 at 10:38
    
Another note on gnome-control-center: for some reason, when an XFCE session is running, most options in the center don't appear for me. I had to log out and in again with a "GNOME session" to get the settings button to appear in the control center. There doesn't seem to be an option to set the default terminal there though? –  Bristol Jun 14 '13 at 11:01
    
Does this work: askubuntu.com/questions/90214/how-to-set-default-program?rq=1 –  Manuel Jun 14 '13 at 16:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.