Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded from Xubuntu 12.10 to 13.04 and not long after (though not immediately after) I have lost network connectivity.

Sometimes I can ping 8.8.8.8 and sometimes I can't. I can't ever ping www.google.com or www.gnu.org. I've confirmed that the problem is not with my DSL bridge/router, since I have normal internet access on my other Xubuntu machine and via wireless (from the DSL router) with my Android device.

Here's what I've tried on the Xubuntu 13.04 system, all to no avail.

First my system and ifconfig output while on a wired connection:

$ uname -a
Linux cypher 3.8.0-23-generic #34-Ubuntu SMP Wed May 29 20:22:58 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

$ ifconfig
eth1      Link encap:Ethernet  HWaddr 00:90:f5:d8:8e:6a  
          inet addr:192.168.254.27  Bcast:192.168.254.255  Mask:255.255.255.0
          inet6 addr: fe80::290:f5ff:fed8:8e6a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:914 errors:0 dropped:0 overruns:0 frame:0
          TX packets:343 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:61498 (61.4 KB)  TX bytes:32037 (32.0 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:336 errors:0 dropped:0 overruns:0 frame:0
          TX packets:336 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:54571 (54.5 KB)  TX bytes:54571 (54.5 KB)

vmnet1    Link encap:Ethernet  HWaddr 00:50:56:c0:00:01  
          inet addr:192.168.254.1  Bcast:192.168.254.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:54 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vmnet8    Link encap:Ethernet  HWaddr 00:50:56:c0:00:08  
          inet addr:172.16.145.1  Bcast:172.16.145.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:55 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

I have VMWare Player and Virtualbox installed, though neither is running at the time. I did have to reinstall VMWare Player and have it recompile itself against the latest kernel after the 13.04 upgrade. That also involved blacklisting kvm and kvm_intel in /etc/modprobe.d/blacklist.conf (which I've since unblacklisted). Not sure if that's relevant.

Attempt to ping:

root@cypher:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_req=1 ttl=48 time=37.9 ms
64 bytes from 8.8.8.8: icmp_req=2 ttl=48 time=37.2 ms
64 bytes from 8.8.8.8: icmp_req=3 ttl=48 time=36.8 ms
^C
--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 36.807/37.327/37.906/0.477 ms

root@cypher:~# ping www.google.com
PING www.google.com (74.125.139.105) 56(84) bytes of data.
^C
--- www.google.com ping statistics ---
9 packets transmitted, 0 received, 100% packet loss, time 7999ms

root@cypher:~# ping 74.125.139.105
PING 74.125.139.105 (74.125.139.105) 56(84) bytes of data.
^C
--- 74.125.139.105 ping statistics ---
10 packets transmitted, 0 received, 100% packet loss, time 9071ms

So I can reach DNS, but not anything else.

I've rebooted many times.

I tried:

sudo dpkg-reconfigure resolvconf

and rebooted. No joy.

I tried Settings Manager > Network Connections > Wired connection 1 > IPv4 Settings and set Method to "Automatic (DHCP) Addresses Only" and set DNS Servers to 8.8.8.8, 8.8.4.4

I tried restarting networking with both:

sudo service networking restart

sudo ifup eth1

Neither fixed the issue (including after rebooting).

My /etc/network/interfaces looked like this:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

I changed it to:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto eth1 
iface eth1 inet loopback

Didn't seem to make a difference. Rebooted. Still not working.

Then I unplugged the wired connection and tried the wireless. I can connect to the wireless router. I cannot ping DNS nor www.google.com. Nor can I log onto the internal web interface of the router (browser just hangs waiting for a connection to it.)

Not sure what else to try or if I should undo anything done above. I don't know what happened to eth0. I thought that's what I'd been using for the past 6 months on this system, so not sure how it changed to eth1 and if that is the problem.

Ideas?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I presume that vmnet1 is the interface to your VMware host-only network and that eth0 is the interface to your home LAN. These subnets' address ranges should not overlap, but your ifconfig output shows that both vmnet1 and eth0 are on subnet 192.168.254/24.

share|improve this answer
1  
OK, so the vmnet1 could be interfering with eth1? (eth0 is no longer mapped for me) Should I try uninstalling my Virtual Machine "players"? Will that remove the vmnet1 and vmnet8 entries? –  quux00 Jun 13 '13 at 22:09
    
The misconfiguration will manifest itself as incorrect routing. You have two interfaces configured as if they are on the same network whereas in fact they are on physically distinct networks. What you should do is either (1) change the address range of your home LAN and eth0; or (2) change the address range of the "host-only networking" virtual VMware network to which vmnet1 is the interface; see, e.g., vmware.com/support/ws5/doc/ws_net_advanced_ipaddress.html. –  jdthood Jun 14 '13 at 8:09
1  
Uninstalling VMWare did restore network connectivity on my host system, so this conflict was the issue. Now going to try reinstalling VMWare using the guide you linked to. –  quux00 Jun 15 '13 at 2:00
1  
Reinstalling worked - vmnet1 is now on 172.168 network, not 192.168 and all is well. Thanks! –  quux00 Jun 15 '13 at 2:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.