Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I'm messing around with Natty a little, and I noticed that all the apps that would normally use the system tray (or "notification area"?) aren't displaying there. Is that a bug, or is that the way it's going to be? I heard something about Ubuntu getting rid of that feature entirely. Is there a way to add it back? I mean, I didn't really like it, either, especially when there were apps that used it unnecessarily, but I can't use CryptKeeper at all now, or easycrypt, and I don't know whether Dropbox has synced without opening Nautilus.

share|improve this question

6 Answers 6

up vote 53 down vote accepted

In versions of Ubuntu prior to 13.04 you have to whitelist the applications if you want to allow them to access the system tray.

Firstly install dconf-tools from the software center ( or by clicking here) Then Press Alt+F2 and enter dconf-editor and run it.

dconf-editor alt-f2 dialog

Now navigate to Desktop -> Unity -> Panel.

configuration editor (dconf-editor) desktop.unity.panel

Now change the value of systray-whitelist to

"all"

Note that setting this to "all" will likely lead to other bugs, as the old notification area is unmaintained, instead consider adding applications you need individually instead of just enabling everything. You can reset it to the defaults by checking out this question:

Do note that the system tray is entirely removed in 13.04 and newer and that older applications that still have not been ported need to be updated:

share|improve this answer
    
I have tried it for lastfm, but a) I cannot paste into the Alt-F2 "thing" (so I've typed it), and b) neither using 'lastfm' nor 'last.fm' in the list (as the only entry) allowed the lastfm icon to be displayed in the notification area. –  blueyed Apr 8 '11 at 17:53
1  
@blue If you open that as a question (and indicate what the exact last.fm application you're using is), we should be able to find a solution. –  belacq Apr 15 '11 at 3:40
    
did the same for pidgin, but still the icon is not shown. raised a query in askubuntu already, but no response. –  Praveen Sripati Oct 19 '11 at 11:25
1  
Note that in 12.10 the key is in /com/canonical/unity/panel/systray-whitelist. –  Felix Feb 12 '13 at 20:05

In Terminal, copy and paste this command

gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

The tip comes from this website;

http://www.webupd8.org/2011/04/how-to-re-enable-notification-area.html

share|improve this answer
1  
...to make the change visible immediately, also restart unity with unity (in terminal or in Alt-F2 launcher), or logout/login, or reboot –  cfi Mar 18 '12 at 20:10
    
This trick worked for 12.10 ... there was no option to do this gconf-editor –  puneet Oct 27 '12 at 9:42
    
@puneet: It's dconf, not gconf –  MestreLion May 9 '13 at 8:53

You can upgrade Dropbox, as in the latest builds it has an indicator on Ubuntu. For other applications, if the developers do not add indicator support for them, you can simply white-list them as Alaukik says, and also notify the developer that they need to fix the application.

share|improve this answer

To show the current systray whitelist:

gsettings get com.canonical.Unity.Panel systray-whitelist

To whitelist all systray indicators:

gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

To append an application to the whitelist, substitute MYAPP at the end of this line:

gsettings set com.canonical.Unity.Panel systray-whitelist "$(gsettings get com.canonical.Unity.Panel systray-whitelist | sed -e "s/]$/, 'MYAPP']/")"

share|improve this answer
    
Have anyone tested this on Ubuntu 12.04? Its not working for me (it was working on previous versions) –  ilius Jun 9 '12 at 4:36
    
As of now, it's working on Ubuntu 12.10 without an issue. –  uygar.raf Dec 28 '12 at 10:45
    
@ilius These commands works on 12.04. –  Cas Jan 26 '13 at 16:52
    
Not working on Ubuntu 13.04 –  Itai Ganot Aug 5 '13 at 16:36
    
Not working on Ubuntu 14.04 LTS. –  musiphil Sep 12 at 22:50

Instead of changing it to 'all' I suggest adding the name of the desired application to the list. With this you avoid all kinds of problems with panel caused by the "all" value.

For example drweb indicator was missing, so I tried to add the command which executes dr web antivirus into the whitelist. The value was like ['JavaEmbeddedFrame', 'Wine', 'Update-notifier']. I changed it to ['JavaEmbeddedFrame', 'Wine', 'drweb-cc', 'Update-notifier'], then I logged out and logged in, and the indicator was on the panel.

share|improve this answer

The best way, and ubuntu version independent is to run dconf-editor, and find (ctrl+F) this string "systray-whitelist" (unless they change it...)

You can edit its value to simply ['all'], you can restore it by clicking "set to default" button also.

Or find out what icons you want to show, one by one and add them there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.