Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Guake is no longer displaying the user and directory in the command prompt like:

<name>@<name>-<computername>:~$

Instead it only displays the $ symbol which only separates the prompt from the command:

$

Also pressing 'tab' actually inserts a tab space instead of completing a command or displaying possibilities.

It was like that when I logged in this morning and I can not think of anything I could have done to change how guake is working. So far I've tried logging in again, restarting my computer, and uninstalling, then installing guake again. No results.

share|improve this question
    
does this happen on guake only or on other terminals also? did you check that your PS1 variable has not been changed in your ~/.bashrc? –  Ciro Santilli Jun 12 '13 at 17:52
    
Yes it is only an issue with my guake terminal. I'm not sure what the PS1 variable was before but 'grep PS1 ~/.bashrc' displays: [ -z "$PS1" ] && return PS1='${debian_chroot:+($debian_chroot)}[\033[01;32m]\u@\h[\033[00m]:[\033[0‌​1;34m]\w[\033[00m]\$ ' PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ ' PS1="[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a]$PS1" Sorry I don't know how to to format this correctly. –  user166705 Jun 12 '13 at 18:07
    
the PS1 variable tell bash what it should print on the login line. It is horrendous because it includes ANSI escape codes for colouring that string. But since the problem is guake only, I don't think the problem lies there... –  Ciro Santilli Jun 12 '13 at 18:20

2 Answers 2

up vote 0 down vote accepted

check that your default shell for guake really is /bin/bash. I set it to /bin/sh and that reproduces your behaviour exactly, since it won't use the bash PS1 line. To see that setting do: right click > preferences > general > default interpreter. By default this was set to <default interpreter>. I do not know how guake determines that, but I'm guessing this is determined by some environment variable and that you had a problem with that enviroment variable. To "fix" the problem for now, try to set the default shell to /bin/bash. To fix it in a better way, find out how guake determines the default interpreter and check that it is correct.

share|improve this answer
    
Setting the default interpreter to /bin/bash does fix the problem! I will see what I can do about finding out how guake determines the default. Hopefully it will stay as /bin/bash. –  user166705 Jun 12 '13 at 18:45

In the Guake options, check that the 'Default interpreter' is . Also maybe check what your user shell is: 'finger ' should give it to you.

share|improve this answer
    
I changed the default interpreter to /bin/bash and that seems to have done the trick. I don't see where finger displays the user shell. –  user166705 Jun 12 '13 at 18:46
    
I needed finger $USER to see my default login shell, but I am not sure that this is how guake determines your login shell or if this has the side effect of changing the default shell. If you clarify this you have my upvote =) –  Ciro Santilli Jun 12 '13 at 18:50
    
When i input 'finger $user' I see 'shell: /bin/bash.' –  user166705 Jun 12 '13 at 18:53
    
Can you tell me how to make commands and such things outlined with a grey box? –  user166705 Jun 12 '13 at 18:54
    
this site uses a version of markdown, for code surround it with backticks. Ex: asdf will give asdf code. I don't think this site supports backticks inside code... AFAIK See help here: stackoverflow.com/editing-help (not very complete reference...). I also suggest you use a more meaningful username so when you get rep you can show off more easily. –  Ciro Santilli Jun 12 '13 at 21:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.