Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Running Ubuntu 13.04

I am trying to configure a machine as a drbl server so I can use clonezilla to master a bunch of machines. But before we get to that point, I was just testing the networking. I have an unmanaged, 1Gb switch. wlan0 is connected to the internet as 192.168.1.149.

I want to setup a second private subnet on eth0.
I tried:

sudo eth0 down
sudo eth0 up
sudo eth0 192.169.1.1

Then, on a windows machine, we manually set ip to 192.169.1.3 We can momentarily ping each other. But when I try to run putty from the pc, suddenly the network is unavailable, and ping no longer works in either direction. The problem is definitely on the linux side, ifconfig eth0 reports no ip address.

Either there is some automated utility changing our network settings, or it could be a firewall.

I tried to run NetworkManager, but get the error "NetworkManager is already running"

share|improve this question
    
I clicked into nm-applet, the icon that shows the wireless state, and there was an entry for wired connection 1. I shut it off in nm-applet, and subsequently have been able to use the network by manually setting IP. I still don't know whether there is a better way to do this? –  Dov Jun 12 '13 at 18:38

1 Answer 1

up vote 1 down vote accepted

If you go to the "Edit Connections" screen from the network drop-down (or the nm-applet), then click on the "Edit" button for your wired connection, you can go to the "IPv4 Settings" tab and change the "Method" drop-down to "Manual", allowing you to add a specific IP address (like 192.169.1.1) for the interface.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.