Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated from 10.04 to 12.04 yesterday. I used Gnome instead of Unity.

I also was configured to have a single row of 6 screens/desktops in the "Workspace Switcher Preferences". After the upgrade this was reset to be two rows of two screens/desktops.

When I set the preferences to again have a single row of 6 screens/desktops I initially see them show up on the bottom toolbar/panel.

The problems start when I try to switch to another screen from screen 0. All decorations, toolbars, etc., disappear. I cannot force a manual switch between screens. All I see is the background.

If I do the Ctrl-Alt-backspace to logout then log in again I get the toolbars/panels but they have been reset to 2 high and 2 wide instead of the single row of 6 that I set in the preferences.

What changed between 10.04 and 12.04 that would cause this and what do I need to do to get back the environment I wish to operate in?

(I am accustomed to having specific apps on specific screens/desktops so changing to a 2x2 model is not desirable.)

Thanks for any help you may provide on this problem.

share|improve this question
    
possible duplicate askubuntu.com/questions/134017/… –  Braiam Jan 10 at 22:24

1 Answer 1

I found the following information on another thread at Workspace switching not working with 12.04 and Gnome classic with effects

The part that worked for me was to use ccsm (compizconfig-settings-manager)

The answer at that link that I found useful was: I initially had the same problem with workplace switching and only the background showing in Gnome classic, but the fix to Alt-Tab does not switch also fixed this - i.e. install compizconfig-settings-manager, and enable "application switcher".

Then if you wish to customize the arrangement of the workplaces from 2x2 to say 4x1, you can do that under Applications -> system tools -> preferences -> compizconfig settings manager -> general -> General options -> Desktop size -> horizontal virtual size = 4, vertical virtual size = 1.

I followed these instruction specifically to set 6 horizontal and 1 virtual and I achieved the desired results. Perhaps this is a bug with the built-in "Workspace Switcher Preferences" where it is not configuring properly whereas ccsm does.

share|improve this answer

protected by Community Jan 10 at 21:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.