Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Alrighty so here is the story:

  • Recently installed Ubuntu 13.04 onto my Dell Inspiron 1745 via live USB setup through unetbootin.
  • Live USB works fine, using a 64bit image, able to browse the net, do the install, run all the updates and whatnot while installing, no issues
  • After installation has completed, no errors are produced (or atleast non that are brought to my attention)
  • I reboot, and what do I see, an Error about Kernel Panic, not-syncing: no init found, suggests to use init= option, and refers me to the init.txt file. As well something about a Runaway Loop Mod (which as far as all my research is concerned seems to be something about wrong architecture (i.e 32bit on 64 bit :/)

Now I am not really brilliant with linux like some of the true guru's here, but I'll go through what I have done so far:

  • Run disk integrity check of my live USB, and a Memory check on my computer (both of which came up with pass)

  • Checked the drives FSTAB, which seemed to show it knew the mount point as '/'.

  • Checked the boot folder (as it seems grub2 is now used) which has both the initrd.img-.. and vmlinuz-.... files.
  • Checked the grub.cfg file, for what options it was using, and it seemed to refer for root='hd0, msdos' which although my experience with system references say it should be sd* or something like that found that Grub2 refers to the first hdd like that now (though did try changing it on some runs)
  • Tried reinstalling multiple time
  • Tried including the init= in the linux section of the bootloader (pushed 'e', and then included the exact location of the initrd file as I assumed that is what it meant)
  • Used the debug mode though found couldn't retrieve any information. I did attempt to look at /var/log/dmesg though found that it said (Nothing has been logged yet.).
  • I have googled on numerous forums, and found majority of fixes don't seem to work.
  • Have attempted both the 32 and 64bit build just to check if that impacted it.

So I am currently out of ideas and wondering if anyone could suggest something to try or a place to look for more info, any assistance would be much appreciated.

share|improve this question
    
Have you checked the boot order of your had drives from the BIOS menu? Make sure that the one you are booting from comes just after the CD/DVD drive if you have one. –  SimplySimon Jun 12 '13 at 7:46
    
Its actually the first in the boot option –  Shadowmancer Jun 12 '13 at 8:09
    
Also should mention, just tested the live USB I am using with the md5sum (and I did get it to check against the right number of blocks as per help.ubuntu.com/community/HowToMD5SUM) and it seems to match with the one on help.ubuntu.com/community/UbuntuHashes –  Shadowmancer Jun 12 '13 at 9:28
    
After talking to the helpful people of the freenode #ubuntu channel, I attempted to modify the boot script of grub2 with the init=/sbin/init command, to try and be specific of where the init command would be, though to no effect –  Shadowmancer Jun 12 '13 at 10:20

1 Answer 1

up vote 1 down vote accepted

Alright ... after many tears and work I have finally solved my issue, though to say the least it is akin to using a bazooka to deal with a single person. So this solution requires a liveusb/livecd of ubuntu, an internet connection and some patience:

  1. Boot up into live usb, and use testing ubuntu.
  2. Open up a terminal
  3. cd /
  4. sudo fdisk -l

    Now with the output of fdisk, determine the drive your actual ubuntu is on. The output should be something like this of fdisk http://paste.ubuntu.com/5758404/ though note there will be an extra line for the liveusb/cd

  5. Next we'll want to mount this, so the command is sudo mount /dev/<device ubuntu is on> /mnt. Now technically you can do it in a number of places but this is for simplicity

  6. This is where things get a bit annoying so you'll have to do some binding:

    • sudo mount --bind /dev/ /mnt/dev/
    • sudo mount --bind /proc/ /mnt/proc
    • sudo mount --bind /dev/pts /mnt/dev/pts
    • sudo mount --bind /sys/ /mnt/sys
  7. After this ensure you are connected to the internet, and then use the following command, this along with the others giving you access to the internet for the next step.

    sudo cp /etc/resolv.conf /mnt/etc/resolv.conf

  8. sudo chroot /mnt

  9. From here its pretty clear cut through apt-get though i'll go through it still.

    1. sudo apt-get update
    2. sudo apt-get dist-upgrade

Now what all this work should have culminated to is the upgrade of the kernel as well as practically all the packages on your hard drive, along with grub2 being updated with the new kernel and whatnot. To ensure proper practices are followed you should unmount the necessary files:

  • sudo umount /mnt/dev/
  • sudo umount /mnt/proc/
  • sudo umount /mnt/dev/pts
  • sudo umount /mnt/sys/
  • sudo umount /mnt/

To be honest I didn't see the point, as it was a live disk though I am sure there is one.

I cannot credit this fix to myself as I am hardly an expert. I got alot of help from here http://ubuntuforums.org/showthread.php?t=1439061 and also my friendly channel surfers on the #ubuntu irc channel on freenode.net

I'll be honest, I don't know if this helps everyone, but it got my ubuntu working and also updated everything.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.