Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.04 LTS 64bit on my computer. I would like to install a F.E.M solver named Code_Aster but i need to install the following dependencies before this:

gfortran, g++, python-dev, python-numpy, python-qt4, zlib1g-dev, liblapack-dev, libblas-dev, tk, grace, bison and finally flex

I tried to run the following command to get them :

sudo apt-get install \
gfortran g++ \
python-dev python-numpy python-qt4 \
zlib1g-dev liblapack-dev libblas-dev \
tk grace bison flex

But it did not work. As the output of the terminal was rather long I tried to install them one by one and get the following messages :

[sudo] password for redg: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package gfortran

to solve this I already read : this discussion and tried to install gfortran "munally" with this file but I failed in both ways.

For python-numpy I get the following

redg@OkDesu:~$ sudo apt-get install python-numpy
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package python-numpy

If found this on the internet but it did not help much. It only confirmed the module was not installed.

As I get similar errors with the other libraries I suggest we just focus on gfortran for now.

Thank you in advance for your help !

Edit1: I failed to mention I failed to mention i'm using a proxy but everything seems to be fine on this side. This is what i found in the apt.conf file :Acquire::http::proxy "http://150.73.3.41:80/";

share|improve this question
2  
Try using sudo apt-get update, then installing after –  DaboRoss Jun 12 '13 at 7:43
    
Thanks for replying DaboRoss. In fact I already tried that as well as : 'code' sudo aptitude -o Acquire::http::No-Cache=True -o Acquire::BrokenProxy=true update sudo apt-get update 'code' –  user166533 Jun 12 '13 at 8:13

1 Answer 1

up vote 0 down vote accepted

You can always try a

sudo apt-cache search "package-name"

to see if the package has been named differently in the repository

share|improve this answer
    
Thank you very much, I just tried it and seems to be working. It seems like I have to specify the version if I want apt-get to work. I feel stupid for not thinking about it... I will mark this Solved as soon as I am done. Thank you again for your help –  user166533 Jun 12 '13 at 23:47
    
Everything has been working fine since gfortran has been isntalled. 'apt-get install python-numpy' even worked without having to write anything elee. I'm not really sure what happened. Anyway case closed. Thank you all for replying. –  user166533 Jun 13 '13 at 1:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.