Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello there Ubuntu Community. I have a question and problem that needs to be solved quick.

Earlier today my computer was working perfect with a dual boot that I had running with Ubuntu 12.04 and Windows 7. I restarted my computer and then all of sudden this Unknown filesystem Grub Rescue this came up. Not needed today. I was not removing the partition or resizing it, all I did was restart my computer and then have this problem occur.

Ive been going through just about every single solution that I can find on the internet. None of which are working and I need a solution soon because I need to run windows 7 CAD software. One big problem is that it is saying that "Mount is denied because the NTFS volume is already exclusively opened. The volume may be already mounted, or another software my use is which could be identified for example by the help of the "fuser" command." I am trying a new solution that involves this software called Hirens Boot CD. I need a solution so here is the info that I got from the computer.

http://paste.ubuntu.com/5756691/

Thanks for the help and I am looking forward to the MUCH needed help.

If there is a way that I can just get windows back on my computer from here without having to go through and Ubuntu please let me know. Otherwise I am gonna need to wipe this computer and find a way to get windows back on so that I can do work. Do windows upgrade disk work? Can best buy do anything to help me out? What can I do?

FIXED!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

In a Way..... let me explain

Through much research, trial, and error, I have found a solution into my boot screen problem on Unknown Filesystem Grub rescue. I found this one "solution" called Hiren's Boot CD. This ISO has dozens on programs on it to help you solve your problems with the Unknown Filesystem and No SUch Partition boot problems. What I did was use the Mini Windows XP program to go and access my Disk Management program in order to delete the Ubuntu Partition, the main source of my booting problem. After the satisfaction of fixing that, I went to boot, in the hopes of the wonderful Windows Logo appearing. Well it didnt, but there was a new sign of hope... my problem changed from "Unknown Filesystem" to "No such Partition", a glimmer of hope. I then ran the Upgrade disk for Windows 7 and used the Repair Computer tool and used this to Fix the Master Boot Record, "bootrec /fixmbr". BUT the second thing, and most important, is the Fix boot code, "bootrec /fixboot" in order to allow for a boot. Once I did this I tried to boot again, not from the BIOS... No Such Partition. :(

Now, I restarted and went into the BIOS, and instead or running more programs, images, and CD's, I clicked ENTER on "Windows Boot Manager"............... THERE APPEARS THE WINDOWS LOGO AND START SCREEN. So all my files are saved, I can run Windows, I have rid of Ubuntu but not my full GRUB problem, and can boot from the BIOS and Run windows. So If this helps you Google Hiren's Boot CD, Burn it onto a disk, run the Mini Windows XP if nothing else is working, Delete the Ubuntu Partition, Boot from the Windows Disk, enter the command prompt, fix the boot and master boot record with "bootrec /fixmbr" and "bootrec /fixboot", Restart, go into the BIOS, ENTER Windows Boot Manager and have fun back on Windows.

Thanks for all the help

-Michael

share|improve this question
1  
It looks like your Linux partition was sda2, and it seems it's been destroyed. What does hexdump -n4096 -C /dev/sda2 show? –  psusi Jun 12 '13 at 3:17
    
You may want to try the GParted Live CD/USB and perform a fsck on all of your partitions. See if that fixes it. –  JamesTheAwesomeDude Jun 12 '13 at 3:24
    
do you now about any tutorials for that? Im just looking to fix and then to uninstall Ubuntu –  Michael Jun 12 '13 at 3:55
    
If you guys can show the command that I need to type in and like instructions that I can follow that would be awesome. Im not the greatest with Ubuntu, I just use for fun and stuff like that. I use windows for CAD work and need it back ASAP –  Michael Jun 12 '13 at 4:00
    
The hexdump -n4095 -C /dev/sda2 shows numbers –  Michael Jun 12 '13 at 4:05
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.