Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I work in a lab, I have 2 Dell blades and a switch. I'm trying to create openStack using juju and MAAS. The blades are connected to the switch and have a private 192... network, and each blade itself is connected to the 10... internet.

I have installed the MAAS server using Ubuntu 13.04 and added the node to it, but the status of the node is still in commissioning! I already checked the hardware clock and it is fine.

How can I fix this issue?

share|improve this question

Not 100% sure if this will answer your question, but I did have this in a virtual environment. I actually just had to reboot the node, it seemed to fix what was needed on the pxe setup the second time around.

share|improve this answer

I am really sorry for not being able to +1 Ross' answer, like it should be,, but being my first post, I cannot simply comment. I have to ANSWER.

I am currently deploying a private cloud using MAAS (Ubuntu 14.04) on a few Dell PE2950s, and found out a few things. The one related to this (fairly old) question is:

1) Once your "nodes" load go on "commissioning", they will be shut down ON PURPOSE, by PXE. You can actually see this on the log related to each node. EDIT the type of power control you have on that node and THEN start it again. I chose Wake on lan, and entered the MAC address detected by MAAS. The NEXT time you start the node, it will boot up and start another routine, which will actually READ the resources from that particular node (amount of memory, number of disks, how many cored, etc). After that is finished, the node will be shut down again, and will be listed as READY on MAAS.

Since we are talking about strange things, here is a few more I noticed and how I solved. Hopefully Google and other spider-indexing systems will find this as well, sharing the info with other people.

I initially tried deploying MAAS in a multi-homed machine, with two network cards, so I could have the cloud controller connected to the internet, but the nodes isolated. Just because I am paranoid. This failed miserably, because once the nodes booted up, they would fail referring to the correct IP address, where to load the images.

The only way to get it working was deploying MAAS with a single NIC (or, at least, only one NIC configured) and they things started to make sense, BUT, you definitely cannot deploy a cloud during your lunch break.

Or, if YOU can, let me know where you work, because you must have a 4 hour lunch break for sure !

I am pretty sure this can be fixed by tweaking a few parameters on configuration files, BUT, first, this is not the goal, second, reconfiguring MAAS, entering (again) the correct IP address did not fix this as one would expect.

Anyway, the objective here is to shed some light on this subject, helping those suffering souls like myself out there.

Cheers.

------ UPDATE --- UPDATE --- UPDATE ---- 15 Jan 2016

I found out that enabling IPMI on the server (probably one of the last prompts before the machine tries to boot; Usually Control E) will allow you to enable and configure IMPI's behaviour, and this is GREAT, because MAAS will use it to control that node, reboot it and shut it down as needed.

I have not tested all the steps on the process, but it looks promising.

Being more detailed, enable IPMI on the NIC used for DHCP, not the other(s). Sounds obvious, but after 3:00am all ideas start to get a bit fuzzy. ALSO, make sure the power mode (on MAAS) of each of the nodes is actually IPMI. MAAS seems to be start enough and test all NICs for IPMI capability.

Looks like MAAS is VERY happy when it controls metal based on IPMI. An alternative (I have not tested) would be setting the nodes to wake-on-lan. This may give a little more latitude regarding timeouts.

--- UPDATE --- UPDATE --- UPDATE --- 16 Jan 2016

IPMI makes a difference, and nodes are automatically powered on and off, BUT, make sure you have the latest firmware installed on your system.

Look for SUU and SLI on Dell's web site. Different versions of IPMI (firmware) behave differently as well.

PLASE NOTE that you still have to select your servers and say "COMMISSION" or "DEPLOY", but MAAS will take care of switching them on of off. No pressing buttons !

ALSO, one of my servers shows ALWAYS with the power on, no matter what. It is probably the firmware thing I mentioned. I had to REMOVE the POWER CABLE and re-connect it a minute latter in order to trigger the right reading on MAAS. Only one unexplored variant here: this specific unit has multiple NICs, off-board. (Just found out you can select the server and say "POWER OFF" to match its actual state).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.