Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I dual boot Ubuntu 13.04 x64/Windows 8 x64 in UEFI mode. After downloading a kernel-update (Linux 3.8.0-23-generic), I can no longer boot into either OS. I have put around 10 hours into this already, and am about ready to throw in the towel and reformat.

I tried:

  • downloading the latest drivers for my nVidia GeForce GTX-460, but this didn't do a thing.
  • installing nvidia-current, nvidia-settings and this likewise did nothing.
  • using a much newer mainline kernel (3.9.x), and then purging it
  • purging and reinstalling linux-image-3.8.0-23-generic, linux-headers-3.8.0-23-generic
  • apt-get remove --purge nvidia* nouveau*
  • reinstalling xorg, unity, unity-2d, ubuntu-desktop, grub-efi-amd64, compiz

Here's a link to my /var/log/Xorg.0.log

Any help is greatly appreciated!

Just in case it helps, I am able to get web access from the root shell prompt.

=====================

UPDATE

Having given up, I formatted my SSD /dev/sda. Replication steps:

(i) I reinstalled Windows 8 Pro in UEFI. Installed Chipset/Nvidia Drivers in Windows. (ii) Shrunk Windows 8 NTFS volume from Disk Manager. Rebooted from live CD and used gparted to create ext4 and linux-swap partitions in empty sector.

/dev/sda1 = Windows Recovery NTFS

/dev/sda2 = EFI vfat

/dev/sda3 = ? mstres

(iii) Installed Ubuntu 13.04 x64 on /dev/sda4, and made /dev/sda5 into a swap partition.

(iv) from a TTY,

# apt-get update
# apt-get install linux-headers-`uname -r` nvidia-current

Only /dev/sda4 (/boot) has a boot flag in gparted.

Everything worked perfectly for 48 hours. I then did a general software update, which included an update to kernel linux 3.8.0-25-generic. Later that day, plugged in speakers in Ubuntu, PC froze. Tried to reboot, but BOTH Windows 8 and Ubuntu boot to black screen.

Here is latest boot-repair:

http://paste.ubuntu.com/5777454/

share|improve this question
    
Updated. Is this what you mean? –  IniquiTrance Jun 11 '13 at 15:37
    
Yes, exactly - editing your question, not adding the info in a comment. –  chaskes Jun 11 '13 at 17:11
    
Well, it sounds as if it boots as you are at a command line. I do not see how a kernel update would affect Windows. At any rate, my guess is a residual xorg.conf, so try sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup and then either reboot or restart X. –  bodhi.zazen Jun 11 '13 at 19:17
    
Tried this, didn't work. Please see updated OP. –  IniquiTrance Jun 18 '13 at 16:05
    
@IniquiTrance - if both windows and ubuntu boot to a black screen, this sounds like a hardware issue - possibly something is about to fail - given your trace, maybe a hard-disk is about to fail? –  fossfreedom Jun 18 '13 at 19:14
show 2 more comments

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.