Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a working Asterisk setup with ttyUSB in /dev folder everytime I connect the device to the USB port. Now I tried the following steps and my ttyUSB1 and 2 disappeared

/etc/init.d/asterisk stop
rmmod option
insmod ./option.ko
insmod ./huawei_voice.ko
/etc/init.d/asterisk start

In hopes to recover, I tried these and still I did not get my ttyUSB working.

rmmod ./option.ko
rmmod ./huawei_voice.ko

I guess I need to do a insmod option, but I get a insmod: can't read 'option': No such file or directory

I guess I need to look into /lib/modules/ folder for options ?

/lib/modules/3.2.0-43-generic-pae/modules.alias        /lib/modules/3.2.0-43-generic-pae/modules.isapnpmap
/lib/modules/3.2.0-43-generic-pae/modules.alias.bin    /lib/modules/3.2.0-43-generic-pae/modules.ofmap
/lib/modules/3.2.0-43-generic-pae/modules.builtin      /lib/modules/3.2.0-43-generic-pae/modules.order
/lib/modules/3.2.0-43-generic-pae/modules.builtin.bin  /lib/modules/3.2.0-43-generic-pae/modules.pcimap
/lib/modules/3.2.0-43-generic-pae/modules.ccwmap       /lib/modules/3.2.0-43-generic-pae/modules.seriomap
/lib/modules/3.2.0-43-generic-pae/modules.dep          /lib/modules/3.2.0-43-generic-pae/modules.softdep
/lib/modules/3.2.0-43-generic-pae/modules.dep.bin      /lib/modules/3.2.0-43-generic-pae/modules.symbols
/lib/modules/3.2.0-43-generic-pae/modules.devname      /lib/modules/3.2.0-43-generic-pae/modules.symbols.bin
/lib/modules/3.2.0-43-generic-pae/modules.ieee1394map  /lib/modules/3.2.0-43-generic-pae/modules.usbmap
/lib/modules/3.2.0-43-generic-pae/modules.inputmap 

What do I do to fix it ? Which folder and file am I looking for here ?

share|improve this question
add comment

1 Answer 1

I restarted the server and all came back to normal.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.