Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

When i try to install some apps i get a message:

linux-headers-generic-lts-quantal : Depend: linux-headers-3.5.0-32-generic but it is not installable

uname -a

Linux ubuntus 3.5.0-27-generic #46~precise1-Ubuntu SMP Tue Mar 26 19:33:56 UTC 2013 i686 i686 i386 GNU/Linux

dpkg -l | grep linux-image

ii  linux-image-3.5.0-23-generic      3.5.0-23.35~precise1         Linux kernel image for version 3.5.0 on 32 bit x86 SMP
ii  linux-image-3.5.0-27-generic      3.5.0-27.46~precise1         Linux kernel image for version 3.5.0 on 32 bit x86 SMP
ii  linux-image-3.5.0-28-generic      3.5.0-28.48~precise1         Linux kernel image for version 3.5.0 on 32 bit x86 SMP
ii  linux-image-3.5.0-30-generic      3.5.0-30.51~precise1         Linux kernel image for version 3.5.0 on 32 bit x86 SMP
ii  linux-image-3.5.0-31-generic      3.5.0-31.52~precise1         Linux kernel image for version 3.5.0 on 32 bit x86 SMP
iU  linux-image-3.5.0-32-generic      3.5.0-32.53~precise1         Linux kernel image for version 3.5.0 on 32 bit x86 SMP
iU  linux-image-generic-lts-quantal   3.5.0.32.39                  Generic Linux kernel image
share|improve this question

marked as duplicate by Avinash Raj, Eric Carvalho, Braiam, BuZZ-dEE, mikewhatever Feb 9 at 15:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
What is the output of sudo apt-get check? –  Braiam Feb 9 at 4:07
add comment

2 Answers 2

install synaptic and find the headers there. It will resolve the dependencies.

share|improve this answer
add comment

If the following command works, then you should be able to install the package.

apt-cache search linux-headers-3.5.0.32-generic

linux-headers-3.5.0.32-generic package is part of the software sources quantal-security, quantal-updates and quantal-proposed.

Hence one of the above software sources has to be ticked in

Ubuntu Software Center >> Edit >> Software Sources >>> Updates

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.