Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have recently updated through software update after installing a fresh installation of Ubuntu 12.04 and my screen resolution is completely messed up. The default screen resolutions at the moment are:

1600 x 1200 (4:3) -- Using this now and it is quite hard to see the screen considering there is no HDMI, just VGA
1280 x 1024 (5:4)
1024 x 768 (4:3) -- Unusable as when I select it, I get a "Fuzzy" screen
800 x 600 (4:3)

I have gone into my xorg.conf file and ensured my vertRefresh and horizontal Sync are all in order and are that specified by my monitors manufacturer. This did not change a thing. I have also tried adding a metamode and mode for the 1366x768 and it still has not worked.

Here is my current xorg.conf file:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 319.17  (buildmeister@swio-display-x86-rhel47-06)  Thu Apr 25 22:28:25 PDT 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 80.0
    VertRefresh     55.0 - 75.0

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"

Section "Screen"
    # Option "metamodes" "1360x768 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes       "1366x768"

I have also tried using xrandr to set the resolution to 1366 x 768 and it does not work. Any tips on allowing me to get my resolution back to normal? Cheers!

share|improve this question

1 Answer 1

Are you sure you have the right and the latest drivers for your graphic cards?

Check if you can update the driver.

share|improve this answer
Yes, I am 100% positive that I do. – ReallyGoodPie Jun 11 '13 at 21:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.