Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Cannot install skype.. lots of dependencies issues.. Please help.... :( Aptitude shows this solution only.. My OS is Ubuntu 12.04 LTS

tau@UBUNTU:~$ sudo aptitude install skype --without-recommends
The following NEW packages will be installed:
  libasound2:i386{a} libaudio2:i386{a} libc-bin:i386{ab} libc6:i386{ab} libdbus-1-3:i386{ab} libexpat1:i386{ab} libffi6:i386{a}

  libfontconfig1:i386{a} libfreetype6:i386{ab} libgcc1:i386{a} libglib2.0-0:i386{a} libice6:i386{a} libjpeg-turbo8:i386{a} libjpeg8:i386{a} 
  liblcms1:i386{a} libmng1:i386{a} libpcre3:i386{a} libpng12-0:i386{a} libqt4-dbus:i386{ab} libqt4-declarative:i386{ab} libqt4-network:i386{ab} 
  libqt4-script:i386{ab} libqt4-sql:i386{ab} libqt4-xml:i386{ab} libqt4-xmlpatterns:i386{ab} libqtcore4:i386{ab} libqtgui4:i386{ab} 
  libselinux1:i386{a} libsm6:i386{a} libstdc++6:i386{a} libtiff4:i386{ab} libuuid1:i386{a} libx11-6:i386{a} libxau6:i386{a} libxcb1:i386{a} 
  libxdmcp6:i386{a} libxext6:i386{a} libxi6:i386{a} libxrender1:i386{a} libxss1:i386{a} libxt6:i386{a} libxv1:i386{a} skype skype-bin:i386{a} 
  zlib1g:i386{a} 
The following packages are RECOMMENDED but will NOT be installed:
  libasound2-plugins:i386 libcups2:i386 libqt4-sql-mysql:i386 libqt4-sql-odbc:i386 libqt4-sql-psql:i386 libqt4-sql-sqlite:i386 qdbus:i386 
  sni-qt:i386 
0 packages upgraded, 45 newly installed, 0 to remove and 0 not upgraded.
Need to get 43.6 MB of archives. After unpacking 93.6 MB will be used.
The following packages have unmet dependencies:
 libc-bin : Conflicts: libc-bin:i386 but 2.15-0ubuntu10 is to be installed.
 libc-bin:i386 : Conflicts: libc-bin but 2.15-0ubuntu10.2 is installed.
 libqt4-declarative : Breaks: libqt4-declarative:i386 (!= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.1 is to be installed.
 libqt4-declarative:i386 : Breaks: libqt4-declarative (!= 4:4.8.1-0ubuntu4.1) but 4:4.8.1-0ubuntu4.4 is installed.
 libdbus-1-3 : Breaks: libdbus-1-3:i386 (!= 1.4.18-1ubuntu1.3) but 1.4.18-1ubuntu1 is to be installed.
 libdbus-1-3:i386 : Breaks: libdbus-1-3 (!= 1.4.18-1ubuntu1) but 1.4.18-1ubuntu1.3 is installed.
 libqt4-script : Breaks: libqt4-script:i386 (!= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.1 is to be installed.
 libqt4-script:i386 : Breaks: libqt4-script (!= 4:4.8.1-0ubuntu4.1) but 4:4.8.1-0ubuntu4.4 is installed.
 libqt4-network : Breaks: libqt4-network:i386 (!= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.1 is to be installed.
 libqt4-network:i386 : Breaks: libqt4-network (!= 4:4.8.1-0ubuntu4.1) but 4:4.8.1-0ubuntu4.4 is installed.
 libqt4-dbus : Breaks: libqt4-dbus:i386 (!= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.1 is to be installed.
 libqt4-dbus:i386 : Breaks: libqt4-dbus (!= 4:4.8.1-0ubuntu4.1) but 4:4.8.1-0ubuntu4.4 is installed.
 libfreetype6 : Breaks: libfreetype6:i386 (!= 2.4.8-1ubuntu2.1) but 2.4.8-1ubuntu2 is to be installed.
 libfreetype6:i386 : Breaks: libfreetype6 (!= 2.4.8-1ubuntu2) but 2.4.8-1ubuntu2.1 is installed.
 libexpat1 : Breaks: libexpat1:i386 (!= 2.0.1-7.2ubuntu1.1) but 2.0.1-7.2ubuntu1 is to be installed.
 libexpat1:i386 : Breaks: libexpat1 (!= 2.0.1-7.2ubuntu1) but 2.0.1-7.2ubuntu1.1 is installed.
 libqt4-xmlpatterns : Breaks: libqt4-xmlpatterns:i386 (!= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.1 is to be installed.
 libqt4-xmlpatterns:i386 : Breaks: libqt4-xmlpatterns (!= 4:4.8.1-0ubuntu4.1) but 4:4.8.1-0ubuntu4.4 is installed.
 libqtcore4 : Breaks: libqtcore4:i386 (!= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.1 is to be installed.
 libqtcore4:i386 : Breaks: libqtcore4 (!= 4:4.8.1-0ubuntu4.1) but 4:4.8.1-0ubuntu4.4 is installed.
 libqt4-sql : Breaks: libqt4-sql:i386 (!= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.1 is to be installed.
 libqt4-sql:i386 : Breaks: libqt4-sql (!= 4:4.8.1-0ubuntu4.1) but 4:4.8.1-0ubuntu4.4 is installed.
 libqt4-xml : Breaks: libqt4-xml:i386 (!= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.1 is to be installed.
 libqt4-xml:i386 : Breaks: libqt4-xml (!= 4:4.8.1-0ubuntu4.1) but 4:4.8.1-0ubuntu4.4 is installed.
 libtiff4 : Breaks: libtiff4:i386 (!= 3.9.5-2ubuntu1.5) but 3.9.5-2ubuntu1.1 is to be installed.
 libtiff4:i386 : Breaks: libtiff4 (!= 3.9.5-2ubuntu1.1) but 3.9.5-2ubuntu1.5 is installed.
 libqtgui4 : Breaks: libqtgui4:i386 (!= 4:4.8.1-0ubuntu4.4) but 4:4.8.1-0ubuntu4.1 is to be installed.
 libqtgui4:i386 : Breaks: libqtgui4 (!= 4:4.8.1-0ubuntu4.1) but 4:4.8.1-0ubuntu4.4 is installed.
 libc6 : Breaks: libc6:i386 (!= 2.15-0ubuntu10.2) but 2.15-0ubuntu10 is to be installed.
 libc6:i386 : Breaks: libc6 (!= 2.15-0ubuntu10) but 2.15-0ubuntu10.2 is installed.
Internal error: the solver Install(libc-bin:amd64 2.15-0ubuntu10 <libc6:i386 2.15-0ubuntu10 -> {libc-bin:amd64 2.15-0ubuntu10 libc-bin:i386 2.15-0ubuntu10}>) of a supposedly unresolved dependency is already installed in step 10
Internal error: the solver Install(libc-bin:amd64 2.15-0ubuntu10 <libc6:i386 2.15-0ubuntu10 -> {libc-bin:amd64 2.15-0ubuntu10 libc-bin:i386 2.15-0ubuntu10}>) of a supposedly unresolved dependency is already installed in step 17
Internal error: the solver Install(libc-bin:amd64 2.15-0ubuntu10 <libc6:i386 2.15-0ubuntu10 -> {libc-bin:amd64 2.15-0ubuntu10 libc-bin:i386 2.15-0ubuntu10}>) of a supposedly unresolved dependency is already installed in step 24
The following actions will resolve these dependencies:

      Keep the following packages at their current version:
1)      libasound2:i386 [Not Installed]                    
2)      libaudio2:i386 [Not Installed]                     
3)      libc-bin:i386 [Not Installed]                      
4)      libc6:i386 [Not Installed]                         
5)      libdbus-1-3:i386 [Not Installed]                   
6)      libexpat1:i386 [Not Installed]                     
7)      libffi6:i386 [Not Installed]                       
8)      libfontconfig1:i386 [Not Installed]                
9)      libfreetype6:i386 [Not Installed]                  
10)     libgcc1:i386 [Not Installed]                       
11)     libglib2.0-0:i386 [Not Installed]                  
12)     libice6:i386 [Not Installed]                       
13)     libjpeg-turbo8:i386 [Not Installed]                
14)     libjpeg8:i386 [Not Installed]                      
15)     liblcms1:i386 [Not Installed]                      
16)     libmng1:i386 [Not Installed]                       
17)     libpcre3:i386 [Not Installed]                      
18)     libpng12-0:i386 [Not Installed]                    
19)     libqt4-dbus:i386 [Not Installed]                   
20)     libqt4-declarative:i386 [Not Installed]            
21)     libqt4-network:i386 [Not Installed]                
22)     libqt4-script:i386 [Not Installed]                 
23)     libqt4-sql:i386 [Not Installed]                    
24)     libqt4-xml:i386 [Not Installed]                    
25)     libqt4-xmlpatterns:i386 [Not Installed]            
26)     libqtcore4:i386 [Not Installed]                    
27)     libqtgui4:i386 [Not Installed]                     
28)     libselinux1:i386 [Not Installed]                   
29)     libsm6:i386 [Not Installed]                        
30)     libstdc++6:i386 [Not Installed]                    
31)     libtiff4:i386 [Not Installed]                      
32)     libuuid1:i386 [Not Installed]                      
33)     libx11-6:i386 [Not Installed]                      
34)     libxau6:i386 [Not Installed]                       
35)     libxcb1:i386 [Not Installed]                       
36)     libxdmcp6:i386 [Not Installed]                     
37)     libxext6:i386 [Not Installed]                      
38)     libxi6:i386 [Not Installed]                        
39)     libxrender1:i386 [Not Installed]                   
40)     libxss1:i386 [Not Installed]                       
41)     libxt6:i386 [Not Installed]                        
42)     libxv1:i386 [Not Installed]                        
43)     skype [Not Installed]                              
44)     skype-bin:i386 [Not Installed]                     
45)     zlib1g:i386 [Not Installed]                        



Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.
share|improve this question
1  
Did you try a sudo apt-get -f install? –  asymptotically Jun 11 '13 at 6:00
1  
Have a look at my answer Here. It might help. –  Mitch Jun 11 '13 at 6:16
    
This looks like a bug with ia32-libs. see askubuntu.com/questions/136394/cannot-install-ia32-libs. I think this is the same thing –  DaboRoss Jun 11 '13 at 7:07
    
@DaboRoss yup.. followed JFBs downgrade and install method in the link you gave.. Could install skype/wine/teamviewer after that.. :) Thanks a lot... Cheers!!! –  Tauseef Jun 12 '13 at 6:54

1 Answer 1

(Disclaimer - I'm a beginner and my english writting skills suck)

I used to have this problem when using fedora, but after some years the packages available in the skype official page seem to have solved the issue, so my suggestion is to download the proper deb package from the official web (12.04 multiarch available here http://www.skype.com/en/download-skype/skype-for-computer/ and double click on it it should star the ubuntu software center, asks for your permissions, and install like any other program) and your skype should work fine.

but if you like to try the hard way ( search trough the web, learn and fix it manually) the folowing info may be helpful.

When in Fedora what i tried (and solved the problem) was the info available in the comments of this post: http://www.piensaenbinario.com/2010/02/como-instalar-skype-en-fedora.html

wich basically says that you need to run 'ldd' command in a terminal (ldd /usr/bin/skype i'm not aware of how is it done in ubuntu or if the command works, and take note of the ones that say "NO MACH" and install all of them manually (sudo apt-get install nameofthedependencyhere) and after that your skype should work fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.